Support » Plugin: WP-PageNavi » [Plugin: WP-PageNavi] wp_pagenavi 2.80

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author scribu

    (@scribu)

    Automatically updated, page links now reference posts not pages

    You mean you replaced wp_link_pages() with wp_pagenavi() and it doesn’t work or what?

    I didn’t change anything, I upgraded from 2.74 to 2.80 now I get

    http://mydomain/last_post_on_homepage

    instead of

    http://mydomain/2 or http://mydomain/3

    Depending on how many pagenavi links are shown on the homepage.

    I’ll stick with 2.74 until an alternative is found.

    Same problem here! Please fix it, pagenavi worked fine until now, but 2.80 doesn’t works (navigation links leads to last post and not to general pagination). :/

    Plugin Author scribu

    (@scribu)

    I’m having trouble reproducing this bug. Please post the file where you use wp_pagenavi() that’s causing trouble on http://pastebin.com

    I’ve posted mine here

    http://pastebin.com/wQe3MB5B, it’s only available for the next 24hrs.

    Not sure what you will learn from this.

    Plugin Author scribu

    (@scribu)

    Yeah, that isn’t much help. I though you were calling query_posts() or something like that. Thanks anyway.

    Scribu, try this please: download Atahualpa theme (last version) and install PageNavi previous version (2.74). Next, update your plugin and ceck the issue. NOTE: don’t modify theme files, Atahualpa support PageNavi natively.

    Thanks for your time. 🙂

    Plugin Author scribu

    (@scribu)

    It seems the code for figuring out if it should display pagination for a list of posts or for a multipart page was very naive.

    This should be fixed in the development version (2.81-beta).

    If you want to use PageNavi for multipart pages, you will have to say so explicitly:

    <?php wp_pagenavi( array( 'type' => 'multipart' ) ); ?>

    2.81 beta works perfectly, thanks for your great job! 🙂

    Yes and I can confirm the version 2.81 ok, but do not want to display the “previous” and “next”.

    You can setting what you need to display, just use the control panel.

    Yes, I used the control panel. In version 2.74 it was ok. After the update it does not appear.

    here is my setting
    At the bottom of the page will result. http://dccmm.dyndns.info

    It seems the code for figuring out if it should display pagination for a list of posts or for a multipart page was very naive.

    This should be fixed in the development version (2.81-beta).

    If you want to use PageNavi for multipart pages, you will have to say so explicitly:

    <?php wp_pagenavi( array( ‘type’ => ‘multipart’ ) ); ?>

    Does above mean that with the 2.8.1 beta the last part is not required?

    @scribu

    First, using WP3.2.1, latest PageNavi…Atahualpa 3.7.3 here.

    I have been struggling today to fix one last issue with my latest blog (the settings, plugins, style etc. of which I intend to apply to other blogs).

    I have noticed that when a ‘page of posts’ (I am confused a little about that terminology, as it seems many use it in differing ways)…let’s say all posts in a category selected by navigation., the plugin and default index.php file of Atahualpa 3.7.3 will display the pagination on the cats page(s) and one can ‘page’ through them….with Atahualpa 3.7.3 (and all older version I have used since ~3.4), when one then clicks the title and is at a single posts page, Atahualpa takes over and we see it’s single post page navigation (note all posts have only one cat and I am displaying just one post per page in ATO options).

    Here is the main issue…All modern browsers then note a change to the ‘layout’ and ‘refresh’ the whole page (not just mod the content)!

    Now, then…I modified index.php to only have one call to the plugin (at top of content loop – maybe that is the issue for display, should the loop be modified for pagination?)and removed all code for the theme’s navigation…but alas, now when we are at a single post, there is not navigation for the cat that I am in….

    <?php // Deactivated since 3.6.5
    	# include 'bfa://content_above_loop';
    	// Uses the following static code instead: ?>
    	<?php wp_pagenavi(); ?>
    
    	<?php while (have_posts()) : the_post(); $bfa_ata['postcount']++; ?>

    and removed any lines that called for ATO options pagination (and also only added this one as when I add any at any point in the loop again, I get two PageNavi sets, regarless of whether we use above code or:

    <?php wp_pagenavi( array( 'type' => 'multipart' ) ); ?>

    I have tested all combinations, I believe…but maybe I missed something at the current intall notes?

    So…what I would like some information on from both the theme and plugin writers is:

    Can we make a navigation ‘area’ <div>, eg, that remains at a fixed size and location in the ‘layout’ without too much fuss, that works the same (in display) whether we are at a home page of posts, a front page, a page of posts, or a single post page, etc., that includes the proper navigation (I am in a cat, I am in tag, eg).

    I think that when all the above are accomplished, sites will render better, navigation will be clearer, and us folks who work with the theme and plugin will have a simpler task at hand.

    Seeing as the plugin and theme are both some of the most downloaded content on WordPress.org, I hope a better integration can be achieved and my notes, suggestions, and comments are taken with the full understanding that I desire to make not just my work easier and sites better, but all those who combine your great efforts.

    Have you played wiht the ‘Keep next/prev. links at ‘ato->Next/Previous Navigation->SINGLE post pages to same post category?’

    theme spport at forum.bytesforall.com

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: WP-PageNavi] wp_pagenavi 2.80’ is closed to new replies.