Support » Plugin: WP-PageNavi » [Plugin: WP-PageNavi] works on main pages, but not for next-page

  • Resolved Moogle Stiltzkin

    (@moogle-stiltzkin)


    For example,

    when you add new posts, it will eventually go to the next page. it works there.

    But when you do a next-page inside 1 post, it does not paginate that using page-navi, only the regular default pagination.

    So how do i get page-navi to work for page-breaked posts/pages as well ?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi Moogle,

    Did you ever find a solution?

    thanks,

    Yes.

    I asked my theme author for help and he gave me a suggestion to add some code to my css.

    So now i have pagination for split pages which is separate from pagenavi.

    Pagenavi handles pagination for main pages and posts on website.

    But split post pagination is handled by this extra pagination code i set.

    You can see the example over at my website [link moderated – it does not contain any solution to this thread]

    Michael

    (@alchymyth)

    Forum Moderator

    Plugin Author scribu

    (@scribu)

    The Development Version (2.80-alpha) of WP-PageNavi handles this.

    Hi scribu,

    Is there a webpage for this pagenavi development version ?

    Plugin Author scribu

    (@scribu)

    Not yet. Just the download link.

    well i’ll test it out. Thx.

    Hi scribu,

    I deleted the old version, installed the new but i did not see the page breaked pages using the page navi.

    Could you take a look at my code ?

    Whats your email.

    I had to add back zwoo’s code to my style.css to have custom pagination for it for the meanwhile 😡

    /* Pagination for split posts */
    
    .entry .page_link{
        margin-bottom: 10px;
    }
    
    .entry .page_link a, .entry .page_link a:link {
        padding: 4px 6px 4px 6px;
        margin: 2px;
        text-decoration: none;
        border: 1px solid #e7e7e7;
        color: #1d8dcb;
        background-color: #FFFFFF;
    }
    .entry .page_link a:visited {
        padding: 4px 6px 4px 6px;
        margin: 2px;
        text-decoration: none;
        border: 1px solid #e7e7e7;
        color: #1d8dcb;
        background-color: #FFFFFF;
    }
    .entry .page_link a:hover {
        border: 1px solid #3b3b3b;
        color: #3b3b3b;
        background-color: #FFFFFF;
    }
    .entry .page_link a:active {
        padding: 4px 6px 4px 6px;
        margin: 2px;
        text-decoration: none;
        border: 1px solid #e7e7e7;
        color: #e56100;
        background-color: #FFFFFF;
    }
    Plugin Author scribu

    (@scribu)

    I forgot to mention that you have to modify your theme’s page.php file:

    Replace this:

    <?php wp_link_pages( array( 'before' => '<div class="page-link">' . __( 'Pages:', 'twentyten' ), 'after' => '</div>' ) ); ?>

    with this:

    <?php wp_pagenavi(); ?>

    *face palm

    Let me give that a shot 😡

    Nope still not working :{

    My theme is Zbench.

    In my case, just had to put that line in single.php since my template does use that php file to properly display post articles, not pages.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: WP-PageNavi] works on main pages, but not for next-page’ is closed to new replies.