Support » Plugin: WP-PageNavi » [Plugin: WP-PageNavi] elegant property theme page navigation problem

  • i am using elegant real estate property theme and for pagination wp page navi plugin have to installed…. but paging show good but work only on page… not in category…. any one have a solution of these
    http://sibinfotech.net/prop/

    very difficult to rectify this prob…because i have set 6 post showing in one time… and then paging showing… now if 7-10 post are available in category then paging not working…. as 11-12 post are set in category.. then paging working properly…

    what a issue here.. help me or suggest me.. plz

    http://wordpress.org/extend/plugins/wp-pagenavi/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author scribu

    (@scribu)

    This is a theme-specific problem. Please contact the theme author.

    Maybe this will help solve your problem, you will need to find the loop code of the template page where the listings are being displayed

    Look at the loop that is setup to display the listings. If the loop uses a custom query name like this example of $blog_query:

    <?php
    $blog_query = new WP_Query($args);
    if ( $blog_query -> have_posts() ) :  while ( $blog_query -> have_posts() ) : $blog_query -> the_post();
    ?>

    you will need to let your pagenavi function at the bottom of the page know by putting the “query” name in the pagenavi array, see the example below:

    <?php
    if(function_exists('wp_pagenavi')){
      wp_pagenavi(array('query' =>$blog_query));
    } ?>

    instead of the default:

    <?php
    if(function_exists('wp_pagenavi')){
      wp_pagenavi();
    } ?>

    may a theme error.. http://sonishkaaproperteez.com/category/residential
    in this page 6-7 properties are not showing.. and i have no idea about to
    $blog_query code… where is it… i have search all thee pages of theme… no idea can u suggest me properly…

    may be this topic will be help full for others…

    after apply this code

    <?php
    if(function_exists(‘wp_pagenavi’)){
    wp_pagenavi();
    }

    Fatal error: Call to a member function get() on a non-object in /home/sonishka/public_html/wp-content/plugins/wp-pagenavi/core.php on line 207

    sorry after apply this code

    <?php
    if(function_exists('wp_pagenavi')){
      wp_pagenavi(array('query' =>$blog_query));
    } ?>

    Fatal error: Call to a member function get() on a non-object in /home/sonishka/public_html/wp-content/plugins/wp-pagenavi/core.php on line 207

    are comming… how to resolve it…

    The solution of @rjbaron helped me to get the page-navi work for a custom post type archive template…. almost…
    It doesn’t work with the permalinks set to %category%/%postname%

    Does anyone have a solution?

    vb078

    (@vb078)

    GOOD

    <?php if (have_posts()) : ?>
         <?php $paged = (get_query_var('paged')) ? get_query_var('paged') : 1; query_posts("category_name=somecat&paged=$paged"); ?>
            <?php while (have_posts()) : the_post(); ?>

    But How to display the first page post (on page template)
    THX 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP-PageNavi] elegant property theme page navigation problem’ is closed to new replies.