Support » Plugins » [Plugin: WP-Options-Manager] can’t enter my admin panel

  • Hi, I activated your plugin, cleaned up the options and now I am not able to enter the admin area. I am shown this:
    “You do not have sufficient permissions to access this page.”

    What have I done wrong?

Viewing 9 replies - 1 through 9 (of 9 total)
  • I think you deleted something you better had not deleted.

    Did you made a database backup? If not, you’re fucked up a bit now.

    Maybe it helps to deactivate all plugins via the database (delete option “active_plugins” with phpmyadmin for example).

    Yeah, I expected the plugin not to list things that aren’t supposed to be deleted.
    Why offer a plugin like this at all? To how many people has this happened?
    And I haven’t backed up the database in quite a time, so yeah I am fucked up.
    Thank you very much plugin maker. NOT.


    Quote (BOLD TEXT Description Page):
    “Important: Only the administrator user should have access to this plugin and should know what he is doing!”

    Quote (FAQ second paragraph):
    “Is it risky to delete options from the database table?

    For sure! So please only delete options if you are really really sure that the options are no longer needed by WordPress or the sky will fall on your head. ;)”

    Quote from “Other Notes (Warranty)”:
    “I have to repeat it again: Only delete options if you really know what you are doing! If there is any maybe do not delete or that option and maybe your WordPress ist lost in space.

    Hint: Backup your database then delete then test and restore the backup if something goes wrong.”

    Sorry, but if you’re so careless not to read a manual before using a software that deletes database entrys of your WP installation, hum… no more comment on that.

    Maybe you’re one of the peoples that needs “warning coffee is hot” printings all over the mc donalds paper cup…

    Hi Raufaser,

    I should start by appreciating your work, it gives non experinced guys like us access into complicated areas.

    I have a problem with my entire website. I am using WordPress Mu 2.7.1 and I installed the WP-Options-Manager Plugin to clean up deprecated Plugin options from my data base. It worked well when I started using it in one of my WPMU Blogs but later I noticed that there was this warning message displaying at the bottom of my blog.

    Warning: file_put_contents(/home/content/n/j/c/njcqi150209/html/wp-content/plugins/wp-options-manager/../../uploads/.wpom.dat) [function.file-put-contents]: failed to open stream: No such file or directory in /home/content/n/j/c/njcqi150209/html/wp-content/plugins/wp-options-manager/wp_options_manager.php on line 839

    I could not understand exactly what it was all about but then I thought activating the Plugin on the WPMU Main Blog could solve the problem so I did just that and then came the catastrophe.

    On the WPMU main blog, I noticed that the Plugin was not functioning well so I went back to the Blog I first installed the Plugin to check-out its behavior but unfortunately I had a NO PAGE FOUND screen. Both the front-end and the back-end of all of my other Blogs display a NO PAGE FOUND screen as well but the WPMU Main Blog is not affected.

    I tried uninstalling the Plugin and removing it entirely from my WordPress Plugins directory but to no avail, the damage had already been done. I guess its now a more serious database problem and I really don’t know where to start from. I have no experience on dealing with databases which is why I went for a Plugin to do the job.

    I am in a fixed now, since I had only made backup just for the first Blog I started from and now I risk losing my entire site because the other Blogs don’t have up to date backups.

    Please can give me some insides on what steps to take?

    Thanks for your support.

    NB: This might be a potential Bug for WPMU. So I suggest you include in the Plugin’s description a warning to WPMU users.

    Hello Njualem,

    I think the problem is, that the plugin trys to rewrite the option “active_plugins” to ensure that WPOM is the first plugin that is loaded. You can find this option in the database table “wp_options”. I think on WP MU there are more than one entrys with this option name, for each blog one – and there is a problem.
    Check the database with phpmyadmin or something and search for this option in the wp_options table.

    Note: “Warning: file_put_contents(/home/co[…]” – that just means that the directory was not writable, which is in generally no problem, and has nothing to do with you main problem.

    I will add a warning for WP MU Users not to use that plugin.

    Thanks Raufaser,

    At least I fell a bit relieved from your quick respond.

    Yes WPMU do have more than one options table in the database, they are named with something like this: wp_1_options, wp_2_options, wp_3_options and so on. I noticed this when I was backing up the first database.

    So if I find this “active_plugins” option, what do I do? Do I delete it? And if Yes, do I delete the “active_plugin” option from all the wp_option tables belonging to all the other Blogs?

    Thanks once more.

    Hi Raufaser;

    I have accessed my database through phpmyadmin and I discovered that the “blog-id” in wp-options table for all the different Blogs has been set to 0.
    wp_1_option, blog_id = 0
    wp_2_option, blog_id = 0
    wp_3_option, blog_id = 0
    wp_4_option, blog_id = 0
    wp_5_option, blog_id = 0 … and so on.

    So how do I get to edit these entries per Blog at one go. You know there are thousands of wp_options entries per Blog and editing them one by one will be just impossible. Can you give me some sql code or query that I can use on each wp_option table to change the “blog_id” value from 0 to the correct values like 1, 2, 3, 4, etc. I believe I can do the editing using phpmyadmin all I will need is some code or query and some guidelines if there are any.

    Thanks for your support.

    Are really all entrys set to blog_id = 0 ?
    I can’t explain that – the code of the wp options manager plugin could not do that. No options are changed until the users deletes something by choice.

    Try the following SQL query:
    SELECT blog_id FROM wp_options WHERE 1 GROUP BY blog_id;

    Please report the result to me.

    Great answer raufaser.
    I thought the plugin job was to detect files that are depracated and not used by wordpress anymore, not ALL files. Who has the time to search through a hay heap of files (sometimes mounting to hundreds if not thousands) to find the ones you want deleted???
    A well written plugin makes things EASIER for users who are not familiar with code talk that takes ages to decipher, not to ruin their blogs.
    True, I should have done the backup but it wasn’t a blog I wanted to keep anyway, so I took the chance and activate this plugin and hoped for the best. And as it turns out, your plugin is NOT the best.
    My advice- rewrite the plugin to list only the files that aren’t being used by wordpress to make it EASY for users like me. I don’t see a purpose of this plugin in this version as it is.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WP-Options-Manager] can’t enter my admin panel’ is closed to new replies.