Support » Plugins » [Plugin: WP-OpenID]: Two bugs in 3.0?

  • I just did a fresh install of version 3.0 of the OpenID plugin, running on WP 2.6.2. I have come across several problems. They may be user error, but if they are then I can’t figure out what I’m doing wrong:

    I set up the plugin to work as an Open ID server for just me. I then tried to leave a comment. Here are the various results that I get:
    1. I am redirected to a login screen. I log in, and the comment is posted (this part works fine)
    2. I am redirected to a login screen. I type in my password incorrectly. I am prompted to try again. I try again and type my password correctly. I am then redirected to my dashboard and the comment is lost.
    3. I am redirected to a login screen. Being a newb to OpenID I put in my OpenID URL again in the field instead of actually logging in. I am prompted again to log in. I figure out I made a mistake, and this time I put in my username and password. I am then:
    a) Given a generic WP error told to fill in my name and email
    b) Given this error:

    Fatal error: Call to a member function needsSigning() on a non-object in /home/jspiers/webapps/new_jspiers/wp-content/plugins/openid/Auth/OpenID/Server.php on line 1495

    The above problems all happen when I try to leave a comment using the OpenID that is created by the plugin. A more serious problem happens when I try to leave a comment using my normal Open ID (from This is what happens:
    1. I fill in my open ID URL in the comment form and am redirected to I login, and am redirected back to my blog. At this point I am given the error telling me to leave my name and email. The comment is lost.

    (I am not sure if this is a bug or if it is expected behavior, but if it is expected behavior then it seems kind of pointless to even use OpenID. The whole point of it is to make life easier on my readers, not harder.)

    Finally, there is one more problem that I encountered. Prior to installing the OpenID plugin I was using phpMyID to run my open OpenID (I did disable phpMyID before playing with the OpenID plugin, so I know there is not a conflict). Anyway, I initially tried to set up the Open ID plugin to just let people log in. I did *not* have it act as a server–instead I left phpMyID running. When I tried to leave comments using the Open ID generated by phpMyID it failed miserably. The login box did not display properly, I got all kinds of errors when I tried to log in, etc. I do not think that the problem is with phpMyID since I have not had any problems using it on other sites.

    I apologize if anything I have listed is user error or something someone else has already written about. I’m just trying to leave some constructive feedback. Unfortunately this plugin is just too buggy for me to use on my Web site right now. It looks like it has a lot of potential, though, so kudos on the work that has been done so far.

Viewing 3 replies - 1 through 3 (of 3 total)
  • it definitely looks like you found a few use-cases I overlooked in regards to logging in. Thanks for excellent explanation, and I’ll make sure to get these corrected for the next release.

    Regarding the “name and email” issue when using MyOpenID, here’s what is happening. You apparently have the option “Comment author must fill out name and e-mail” selected. Normally, the name and email are checked for as soon as the comment is submitted. With the OpenID plugin, that check is suspended until after the OpenID authentication is completed. That gives the commenter the opportunity to get the name and email address information from their OpenID provider. If the attributes are not sent over from the OpenID provider, nor are they supplied in the comment form, then the check fails and you get the error message you describe. It seemed to make sense to me, that if a blog owner checks the option that they want the name and email of the commenter, then that should apply whether they commenter used OpenID or not. Would you rather not perform that check for OpenID comments? Or at the very least, I could prompt the user for the missing information, so their entire comment isn’t lost.

    You may also be interested in another plugin I wrote to deal with this exact issue:

    I’m unable to reproduce #2 when using the built-in OpenID provider. I can reproduce #3 and I know what the problem is, but it’s fairly non-trivial to fix given how the provider works. I’m not able to reproduce any errors with phpMyID either. I’m not sure why they would conflict anyway, given that they shouldn’t ever be running in the same PHP process. Unless you’ve got some kind of WordPress plugin for phpMyID?

    Indeed, I’m also getting #3 on my site when trying to use the plugin as an OpenID provider.

    I’m very interested in getting this fixed — anything you need from us to help?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP-OpenID]: Two bugs in 3.0?’ is closed to new replies.