Support » Plugins and Hacks » [Plugin: WP-OpenID] No longer able to post comments

  • [I realized I ought to post here rather than the dev’s blog, especially since I mistakenly cited the wrong WP version.]

    I installed v2.2.1 (on WP 2.5.1), and no longer seem to be able to post comments when the plugin is activated. I get the following error when wp-comments-post.php runs:

    You must submit a comment using the comment form.

    I checked the plugin’s status info, which displays a failure for Big Integer support:

    [FAIL] Big Integer support: The OpenID Library is operating in Dumb Mode. Recommend installing GMP support.

    Are there any workarounds I could apply? Comments can be posted if I turn off openid, but of course that means no openid support for my site.

    Thanks in advance!

    Note: I was running wp-openid 2.2.1 on my test site sairuh.org, but I’ve temporarily turned it off.

    http://wordpress.org/extend/plugins/openid/

Viewing 7 replies - 1 through 7 (of 7 total)
  • I tested this with WordPress 2.6 on a local installation (using MAMP, fwiw), and I’m still unable to post comments, with the same “You must submit a comment…” message.

    Interestingly, I don’t get the Big Integer support failure notice. (Then again, I’m almost sure the PHP versions between my hosting service and my local machine differ. So I’m not sure if Big Integer Support would be relevant for my particular issue here…)

    I think I’ve narrowed it down to a conflict with the Filosofo Comments Preview (v1.0.5) plugin. When I disable Comments Preview, comments (using openid auth) post properly.

    Here is how to solve it — open filosofo-comments-preview.php and replace (line 77) this:

    if ( false !== stristr($_SERVER['REQUEST_URI'], 'wp-comments-post.php') )
    wp_die( __('You must submit a comment using the comment form.','filosofo-comments-preview') );

    with:

    if (!class_exists('WordPressOpenID')) {
    	if (false !== stristr($_SERVER['REQUEST_URI'], 'wp-comments-post.php'))
    		wp_die( __('You must submit a comment using the comment form.','filosofo-comments-preview') );
    }

    kasparsd, that did the trick! Thanks a bunch for this workaround.

    Question for Austin (developer of Filosofo Comments Preview): Would you be able to roll in this fix for the next version of your plugin?

    (Hm, I wonder if this also occurs with the Ajax/Live comment preview plugins, where WP-OpenID is used…)

    WP-OpenID plugin 3.0 has been released. The have renamed the class, so here is an updated solution – change

    !class_exists('WordPressOpenID')

    to

    !function_exists('is_comment_openid')

    @kasparsd: it’s worth noting that the “is_comment_openid” function has been around since version 1.0 of the plugin, so it should work for all versions, old and new.

    Hello again,

    Things had been working for a while, but when I upgraded to the latest versions of WordPress (2.7.1), OpenID (3.2) and Filosofo Comments Preview (1.5), I’ve run into another, potentially related problem. If someone tries to leave a comment *without* using an OpenID, they get prompted to enter a Name and Email — even though those fields are filled out. The Website field in this case is empty.

    Error: please fill the required fields (name, email).

    This is strange since my basic Discussion setting has only “Comment author must fill out name and e-mail” selected. I don’t require registration. Fwiw, I’ve got an entry for testing comments at http://sairuh.org/2008/10/22/zowie/ — where both of the plugins are currently enabled.

    Any suggestions on how to work around this issue? Thanks (again) in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP-OpenID] No longer able to post comments’ is closed to new replies.