WordPress.org

Forums

No Category Base (WPML)
[resolved] [Plugin: WP No Category Base - WPML compatible] Updated to WordPress 3.4 Plugin Stopped Working (14 posts)

  1. Jason M Rogers
    Member
    Posted 4 years ago #

    A great plugin but after updating to wordpress 3.4 it seems to have stopped working and the 'category' base re-appears. I tried the obvious things, de-activated and re-activated, re saved permalink structure etc.

    http://wordpress.org/extend/plugins/no-category-base-wpml/

  2. Jason M Rogers
    Member
    Posted 4 years ago #

    As a temporary measure I opened up the WordPress core file 'taxonomy.php' in the folder 'wp-includes' and removed the word 'category' from the slug rewrite code.

    http://core.svn.wordpress.org/branches/3.4/wp-includes/taxonomy.php

  3. Christian Foellmann
    Member
    Posted 4 years ago #

    please reopen!!

    This plugin is totally necessary

  4. HalogenDan
    Member
    Posted 4 years ago #

    Yes, please reopen! This is not resolved, and affects my site in a BIG way. Would really hate to modify core files.

  5. HalogenDan
    Member
    Posted 4 years ago #

    Okay, I've worked out how to fix this with relative ease.

    1. Open up no-category-base-wpml.php

    2. Find:

    $wp_rewrite->extra_permastructs['category'][0]

    3. Replace it with:

    $wp_rewrite->extra_permastructs['category']['struct']

    Enjoy

  6. Christian Foellmann
    Member
    Posted 4 years ago #

    That works! THANK YOU very much!!!

    Lets hope the dev integrates it into the next version soon

  7. Dave James Miller
    Member
    Posted 4 years ago #

    That's great, thank you HalogenDan!

  8. Jools1976
    Member
    Posted 4 years ago #

    Yes, that works, thank you! ;-)

  9. DeskCoder
    Member
    Posted 4 years ago #

    @HalogenDan, Awesome, that worked ... now don't forget to regenerate your sitemaps!

  10. mines.io
    Member
    Posted 4 years ago #

    I don't know why this topic was marked as resolved without being so.

    I've added the code to fix the issue for WordPress 3.4. Many thanks for your feedback.

    Please let me know if there are any more issues.

  11. Christian Foellmann
    Member
    Posted 4 years ago #

    thx.

    Good work of the community. A fine example why open-source works so well.

  12. Sergey Biryukov
    WordPress Dev
    Posted 4 years ago #

    I've added the code to fix the issue for WordPress 3.4

    The plugin appears to be working fine with WordPress 3.4 now. I guess you should update the "Tested up to" version in readme.txt.

  13. Pancho Perez
    Member
    Posted 4 years ago #

    Great plugin, thanx for the "update" to 3.4 it works :)

  14. mines.io
    Member
    Posted 4 years ago #

    Thanks for the heads up Sergey. Did that!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • No Category Base (WPML)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic