WordPress.org

Support

Support » Plugins and Hacks » No Category Base (WPML) » [Plugin: WP No Category Base – WPML compatible] 301 not working for attachments

[Plugin: WP No Category Base – WPML compatible] 301 not working for attachments

  • Hi,

    The plugin is working great for posts but fails to redirect attachments

    My existing permalink was /blog/%postname%/

    I moved /blog/ to root and I changed permalinks to /%category%/%postname%/ to get rid of /blog/%postname%/

    The plugins correctly redirects /%postname%/ to /%category%/%postname%/ but fails to redirect /%postname%/image1/ to /%category%/%postname%/image1/

    Also /blog/%postname%/image1/ still works, this might result into duplicate content.

    http://wordpress.org/extend/plugins/no-category-base-wpml/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    I don’t clearly understand what you did when moving “/blog” to root. Could you please explain it further?

    Thanks,
    Mines.

    I was running a blog on my site but not in the root, I was running it in a directory called /blog/. The permalink for this blog was /%postname%/
    There were six categories.

    Now I have decided to move the blog to root of my site and change permalinks to /%category%/%postname%/ so that the site has a better structure and not all the posts are in the root of the site with /%postname%/ and needed to get rid of the “category” base.

    All the /%postname%/ (slugs) are currectly redirected to their respective categories and I see URL as /%category%/%postname%/

    However attached images/media pages from these old urls posts do not redirect, so all the traffic from search engines results into 404 pages.

    Ok,

    I am looking into this now. Please let me investigate.

    Thanks,
    Mines.

    Hi,

    Have we found a solution to this? I’m still not able to move my site as there is no other way of getting this done.

    Hi,

    Not yet. Please note that my available support time is limited. However I will try to check on this as soon as I can.

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP No Category Base – WPML compatible] 301 not working for attachments’ is closed to new replies.
Skip to toolbar