WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Nivo Slider] making wp-nivo-slider compatible with IE6

[Plugin: WP Nivo Slider] making wp-nivo-slider compatible with IE6

  • gervasioantonio
    Member

    @gervasioantonio

    While creating a website that SHOULD be compatible with IE6, I was forced to find a solution to make Nivo-Slider also compatible with that damn old browser. Turns out it’s not that difficult.

    Step 1) Using an image editor (I used Paint.NET), split arrows.png in two separate images: the left half becomes arrow-prev.png and the right half becomes arrow-next.png. Original image is 62×34 pixels, so you’ll end up with two images measuring 31×34 pixels each.

    Step 2) Open nivo-slider-ie6.php file, find line # 159 (that’s between </style> and <script type="text/javascript"> tags) and paste the code below:

    <!--[if lt IE 7]>
    <style type="text/css">
      * html a.nivo-nextNav {
        background: none;
        filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(src="<?php echo WP_PLUGIN_URL . "/wp-nivo-slider/"; ?>images/arrow-next.png", sizingMethod="crop");
        }
    
      * html a.nivo-prevNav {
        background: none;
        filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(src="<?php echo WP_PLUGIN_URL . "/wp-nivo-slider/"; ?>images/arrow-prev.png", sizingMethod="crop");
        }
    </style>
    <![endif]-->

    Save the file and test it. Now Nivo-Slider should work in IE6.

    http://wordpress.org/extend/plugins/wp-nivo-slider/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: WP Nivo Slider] making wp-nivo-slider compatible with IE6’ is closed to new replies.