Support » Plugins and Hacks » WP MtG-Helper » [Plugin: WP MtG-Helper] Plugin will not Activate

  • Resolved adamra4

    (@adamra4)


    I get this message:
    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_VARIABLE in /home/ajm/public_html/wp-content/plugins/wp-mtg-helper/mtg_helper_options.php on line 1

    I made sure my host was using PHP 5 (I even tried PHP 4). I added “SetEnv PHP_VER 5” to my htaccess file. I tried WP v3.1.2 as well as the newest version (v3.3.1). Both v1.2 & 1.2.5 of the plugin gave the same error. Is there anything I can do to solve this? I have searched Google for a while and tried everything I could find but nothing seems to work. Thanks again for any help.

    http://wordpress.org/extend/plugins/wp-mtg-helper/

Viewing 3 replies - 1 through 3 (of 3 total)
  • After searching high and low…I figured it out on my own. It seems that the file “mtg_helper_options.php” is all on 1 line from the download (or gets that way after I extract it. No other file gets like that). I opened it in Dreamweaver and it shows normal (multi-lines). So I edited the file from CuteFTP and copied the code from Dreamweaver over so it looks correct on the FTP side and IT WORKS. I am running WP v3.3.1 and MTG Helper v1.2.5. Also running PHP5 (tested with a phpinfo page) with no need to edit anything else (like .htaccess). Hope this helps someone.

    Now I am getting this on every page:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘mtgh_list’ was given in /home/ajm/public_html/wp-includes/plugin.php on line 170

    Any suggestions?

    Looks like “mtg_helper_parser.php” did the same thing as above (all code on 1 line). Applied the same fix as above and all seems to be working.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP MtG-Helper] Plugin will not Activate’ is closed to new replies.