Support » Plugin: WP-Members Membership Plugin » [Plugin: WP-Members] Register form

  • Resolved wahwahchris


    I’m setting up a wpml site with one page that is members only.
    I’ve solved the membes-area slug with adding the members-area-newlanguage in the plugins core.

    I want the register form only to show up on the members area page.
    Now its all over my frontpage image slider when i’m not logged in..
    Default settings is not blocked on post and pages because only one page with som subpages is the members area.

    Any tips?

    regards Chris

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Chad Butler


    I’ve never tested WP-Members with WPML, so I can’t speak to compatibility issues. Also, when changing anything, especially the core, you have to be very cognizant of what you are changing. You are doing something that is not supported and also not compatible with automatic upgrades.

    With those caveats, I would say first, make sure you are adding to the conditional logic rather than adding another code block. Second, I would double check that you’ve changed the appropriate logic in both the code block that builds the members page, and also the beginning of wpmem_securify where it determines the value of WPMEM_BLOCK_PAGES.

    Hope that helps.

    I dont think its my changes to have a register page of each lanugage thats casuing the problem.

    i’ve only added ||’members-area-dk’||’members-area-se’

    in the members core to get around the slug issues of multiple page-slug with the same register/members possibilites.

    if ( is_page() && !is_page(‘members-area’||’members-area-dk’||’members-area-se’) && !is_page(‘register’) )

    The only problem i experience now is that if not logged inn the register form is in the center of the home page.

    sorry myfault .. changed back to se if that was the issue.. and it was.

    The ||’members-area-dk’||’members-area-se’ did the trick so each members-page got the register form, what else do i need to change if i want that to work ?

    The trouble is that i need the members-slug/shortcode to work on two other page slugs for the other two languages..
    Any thoughts ?

    regards Chris

    Plugin Author Chad Butler


    I would say you need to carefully evaluate every instance of is_page(‘members-area’) logic. There are 5 places where this is used in wpmem_securify.

    I’ve changed all the five places the first time around.
    The members-area slugged workd on those pages.
    The only problem was when not logged inn.. where do i control where the register form appears.. i want it only on those pages.

    regards Chris

    Plugin Author Chad Butler


    Where exactly is form showing that it’s not supposed to be? The form will show on any page that is blocked (unless, of course the user is logged in). So if we are talking about it showing on a blocked page, then we can assume the plugin is working correctly (in which case we need to discuss how to customize the display on blocked pages).

    If that’s not the case and you are getting the form on pages that are not blocked, double check that you have the appropriate setting for “Block Posts by default” and “Block Pages by default” (You mentioned that you have these unchecked, correct?).

    If that is not the problem, then I suspect that the new logic you added is resulting in $chk_securify being set to “block” (I incorrectly said WPMEM_BLOCK_PAGES in my original post).

    Thanx for the input.
    Regards Chris

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP-Members] Register form’ is closed to new replies.