WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP-Members] reCaptcha doesn't work

[Plugin: WP-Members] reCaptcha doesn't work

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Chad Butler

    @cbutlerjr

    If there is nothing inside the frame, that sounds like the API key does not match the domain you are running it on. A common problem is getting a key for “mydomain.com” and testing it on “localhost” – that won’t work.

    Double check https://www.google.com/recaptcha/admin/list to make sure the domain you are testing/running on is in your list of domains.

    Hello,
    Thank you for your prompt response. I check the link you mentioned, and it shows my domain http://www.kaoli.com.tw.
    I do not test my site on localhost.
    Since the site hasn’t ready to launch, I add a sub-folder for the site temporarily. Do you think it is the root cause?
    Here is my registration page for your reference:
    http://www.kaoli.com.tw/readytogo/signup/

    Plugin Author Chad Butler

    @cbutlerjr

    It looks like things are loading, so I wonder if it has something to do with the language you are using? I’m not sure on that one.

    If you need to load something custom for the reCAPTHCA, there is a filter hook for that in the plugin. Here is the framework for that:

    <?php
    add_filter( 'wpmem_recaptcha', 'my_recaptcha' );
    
    function my_recaptcha( $recaptcha ) {
    
    	// filter $recaptcha
    
    	return $recaptcha;
    }
    ?>

    Here is information on internationalizing the reCAPTCHA:

    https://developers.google.com/recaptcha/docs/customization#i18n

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP-Members] reCaptcha doesn't work’ is closed to new replies.