WP-Members: Membership Framework
[Plugin: WP-Members] reCaptcha doesn't work (4 posts)

  1. james66618
    Posted 3 years ago #

    I turned on reCaptcha for registration and provided private key and public key as well. However, reCaptcha on my registration page is empty.
    I can see the reCaptcha frame, but there is nothing inside.
    Can someone help me on this?


  2. Chad Butler
    Plugin Author

    Posted 3 years ago #

    If there is nothing inside the frame, that sounds like the API key does not match the domain you are running it on. A common problem is getting a key for "mydomain.com" and testing it on "localhost" - that won't work.

    Double check https://www.google.com/recaptcha/admin/list to make sure the domain you are testing/running on is in your list of domains.

  3. james66618
    Posted 3 years ago #

    Thank you for your prompt response. I check the link you mentioned, and it shows my domain http://www.kaoli.com.tw.
    I do not test my site on localhost.
    Since the site hasn't ready to launch, I add a sub-folder for the site temporarily. Do you think it is the root cause?
    Here is my registration page for your reference:

  4. Chad Butler
    Plugin Author

    Posted 3 years ago #

    It looks like things are loading, so I wonder if it has something to do with the language you are using? I'm not sure on that one.

    If you need to load something custom for the reCAPTHCA, there is a filter hook for that in the plugin. Here is the framework for that:

    add_filter( 'wpmem_recaptcha', 'my_recaptcha' );
    function my_recaptcha( $recaptcha ) {
    	// filter $recaptcha
    	return $recaptcha;

    Here is information on internationalizing the reCAPTCHA:


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Members: Membership Framework
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic