WordPress.org

Forums

WP-Members
[resolved] http 405 resource not allowed (2 posts)

  1. Simpso
    Member
    Posted 2 years ago #

    Hey,

    I am trying to get wp-members up and running on a windows xp professional server with wordpress 3.4.2 and PHP 5.3.10. I am using IIS5.1 (built in with any win xp pro 32bit setup) rather than apache.

    When submitting the registration form (or update information form) I get an error "HTTP 405 Resource not allowed". I've tried to find info about this as it sounds like an IIS configuration issue and came across this and a page with some possible causes. However when attempting fixes I get nowhere.

    Any ideas on how I can get a form to work? (I've tried another plugin that allows you to easily create a user registration page but I get the same error, so I know it's really not an issue with your plugin, but I thought you would have a better idea of how to fix this than me)

    I have no problems when creating users in the wordpress admin panel, and I am positive my php install is linked properly as I have tested a few pages.

    Anything at all would be a great help,

    Thanks

    -Simpso

    http://wordpress.org/extend/plugins/wp-members/

  2. Chad Butler
    Member
    Plugin Author

    Posted 2 years ago #

    What are your permalink settings?

    If you are using "pretty" permalinks in IIS, this could run into problems on POST items such as form submissions. This is because there is a redirect that happens after the form post, and IIS generally is going to presume POST method on that as well, which it won't allow because it will assume you are posting to a directory (as the redirect would be something like http://mysite.com/my-page/).

    You could test this theory by using the default permalinks (http://mysite.com/?p=123). Although that's not really a solution, it might help you track down if this is actually the case or not. And if it is, at least you may be able to track down a solution.

    The real solution would be to use Apache rather than IIS, though ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Members
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic