WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP-Members] help – parse error

[Resolved] [Plugin: WP-Members] help – parse error

  • I just uploaded and activated the wp-members plugin. The quick start is great and I think this is going to add the functionality that I need. I am a beginning wp user. The following error is on every page. ‘Parse error: syntax error, unexpected ‘>’ in /home/…/wp-content/themes/twentyten/comments.php on line 2′
    I don’t know how to fix this.

    http://wordpress.org/extend/plugins/wp-members/

Viewing 1 replies (of 1 total)
  • Plugin Author Chad Butler

    @cbutlerjr

    Make sure that this code is at the absolute very top of the page:

    <?php if (!is_user_logged_in() && !get_post_custom_values('unblock')) { $post->post_password = wpmem_generatePassword(); } ?>

    In the error you posted, I see you are using the twentyten theme. The error you are getting would occur if you put this code snippet after the first “<?php”. Make sure it is before that.

    Hope that helps.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] [Plugin: WP-Members] help – parse error’ is closed to new replies.