Support » Plugins and Hacks » [Plugin WP Mail SMTP]

[Plugin WP Mail SMTP]

Viewing 10 replies - 1 through 10 (of 10 total)
  • I think you’re on a Windows host right? For some reason WordPress behaves slightly differently on Windows hosts. I’ve seen this issue before, but it only applies to a small number of cases. Thanks for reminding me though, I believe there’s probably a simple fix which I’ll look into.

    The issue doesn’t affect the functioning of the plugin under normal circumstances.

    Hello Callum, this is hosted on Unix, not Windows.
    I hope you can take a look…. This is a test site. I need to transfer my production domain on this hosting, already this week, and I would like to have the plugin working.

    What do you think?

    The plugin works fine.

    It’s only the email test that doesn’t work properly after you clicked to save the options. So long as you click on the Options > Email menu, then use the test feature, it works fine. Every other aspect of the plugin works fine.

    Yes, I think so… I can’t really test it in this new server (I am in the middle of a change of hosting provider), because there are problems with the SNMP credentials.

    I will test it soon… I hope everything will be fine.

    Thank you for your support
    I am glad that this is a known issue and it doesn’t affect the real functionality of the plugin. However if you could fix it it would be excellent :)))

    Thanks again

    Hello, it was working fine. Then I upgraded to 3.2 and I get this error when I try to send a test email:

    SMTP -> FROM SERVER:220 server.pl ESMTP IdeaSmtpServer v0.70 ready.
    SMTP -> FROM SERVER: 250-server.pl Hello code.server.pl [], pleased to meet you 250-PIPELINING 250-ENHANCEDSTATUSCODES 250-SIZE 250-8BITMIME 250-AUTH PLAIN LOGIN 250-AUTH=PLAIN LOGIN 250 HELP
    SMTP -> FROM SERVER:250 2.1.0 Sender address accepted
    SMTP -> FROM SERVER:250 2.1.5 Recipient address accepted
    SMTP -> FROM SERVER:354 Go ahead...
    SMTP -> FROM SERVER:250 2.0.0 Message accepted. 
    Fatal error: Cannot access protected property PHPMailer::$language in /wp-content/plugins/wp-mail-smtp/wp_mail_smtp.php on line 197

    What to do?

    This is fixed in 0.9.1 which is taking a while to go live on WordPress.org, I’m not sure why. It’s only a cosmetic issue.

    fyi, I just installed version 0.9.0 on a new WordPress 3.2 on a Windows server and it’s working fine for me. Still, I don’t see 0.9.1 available on WordPress.org quite yet, I hope it magickally appears soon as I’d like to install it just to have the latest.

    My bad, I forgot to change the version number in the PHP file itself as well as the readme file. Now done and 0.9.1 is live.


    v0.9.1 looks good now, thanks!!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin WP Mail SMTP]’ is closed to new replies.