WordPress.org

Forums

WP Mail SMTP
Will not connect to GMAIL SMTP with Linux host (5 posts)

  1. ccolotti
    Member
    Posted 3 years ago #

    I have seen that this is an issue. Will there be a fix soon? I am able to connect to GoDaddy SMTP, but they limit to 250 relays per day. When I try to connect to GMAIL it says cannot connect to host. So it has to be something with GMAIL and I have set it up with SSL/465 same as any other email client.

    I host wordpress on linux and I have seen that as the issue. Is there a code change to make it work int he meantime?

    http://wordpress.org/extend/plugins/wp-mail-smtp/

  2. Callum Macdonald
    Member
    Plugin Author

    Posted 3 years ago #

    I believe GoDaddy block outgoing SMTP connections to other mail hosts on port 25, I'm not sure about other ports. Many, many users have reported success with this plugin and gmail.

    [Disclosure: I am the plugin author]

  3. shendun172
    Member
    Posted 3 years ago #

    I have the same problem when I use "WP Mail SMTP" plugin and my gmail account to send mail. The error is: "SMTP -> ERROR: Failed to connect to server: Permission denied (13) SMTP Error: Could not connect to SMTP host. ". My settings:

    define('WPMS_ON', true);
    define('WPMS_MAIL_FROM', 'From Email');
    define('WPMS_MAIL_FROM_NAME', 'From Name');
    define('WPMS_MAILER', 'smtp'); // Possible values 'smtp', 'mail', or 'sendmail'
    define('WPMS_SET_RETURN_PATH', 'false'); // Sets $phpmailer->Sender if true
    define('WPMS_SMTP_HOST', 'smtp.googlemail.com'); // The SMTP mail host
    define('WPMS_SMTP_PORT', 465); // The SMTP server port number
    define('WPMS_SSL', 'ssl'); // Possible values '', 'ssl', 'tls' - note TLS is not STARTTLS
    define('WPMS_SMTP_AUTH', true); // True turns on SMTP authentication, false turns it off
    define('WPMS_SMTP_USER', 'myname@gmail.com'); // SMTP authentication username, only used if WPMS_SMTP_AUTH is true
    define('WPMS_SMTP_PASS', 'mypasswd'); // SMTP authentication password, only used if WPMS_SMTP_AUTH is true

    I have no problem for this settings on my Thunderbird. Any idea about it? Thanks!

  4. Callum Macdonald
    Member
    Plugin Author

    Posted 3 years ago #

    @shedun172: It's probably something in your PHP configuration, either SSL is not enabled or maybe fopen() is restricted. I recommend asking your server admin.

    [Disclosure, I'm the plugin author.]

  5. skylar180
    Member
    Posted 3 years ago #

    Hi Callum,
    I can't get to work either. I'm hosted at GoDaddy but wanted to use Gmail's SMTP server because I'm hoping it will look less like spam.
    Anyway, After I press test, the out put is very long but it ends like this:
    ["language:protected"]=>
    array(17) {
    ["provide_address"]=>
    string(54) "You must provide at least one recipient email address."
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["execute"]=>
    string(19) "Could not execute: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["recipients_failed"]=>
    string(45) "SMTP Error: The following recipients failed: "
    ["data_not_accepted"]=>
    string(30) "SMTP Error: Data not accepted."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["signing"]=>
    string(15) "Signing Error: "
    ["smtp_error"]=>
    string(19) "SMTP server error: "
    ["empty_message"]=>
    string(18) "Message body empty"
    ["invalid_address"]=>
    string(15) "Invalid address"
    ["variable_set"]=>
    string(30) "Cannot set or reset variable: "
    }
    ["error_count:private"]=>
    int(1)
    ["sign_cert_file:private"]=>
    string(0) ""
    ["sign_key_file:private"]=>
    string(0) ""
    ["sign_key_pass:private"]=>
    string(0) ""
    ["exceptions:private"]=>
    bool(false)
    }

    The SMTP debugging output is shown below:

    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

    SMTP Error: Could not connect to SMTP host.

    From Email

    Callum , any ideas what to do?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Mail SMTP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic