WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Mail SMTP] SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

[Plugin: WP Mail SMTP] SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

  • Hi

    No matter how I configure the plug in to send a test email it wont. I have configured it for gmail using ssl and tls. I have double checked the settings and even deactivated every other plugin in an attempt to see if there were any conflicts but still no luck
    Any suggestions? Log shown below:
    The result was:

    bool(false)

    The full debugging output is shown below:

    object(PHPMailer)#149 (45) {
    [“Priority”]=>
    int(3)
    [“CharSet”]=>
    string(5) “UTF-8”
    [“ContentType”]=>
    string(10) “text/plain”
    [“Encoding”]=>
    string(4) “8bit”
    [“ErrorInfo”]=>
    string(43) “SMTP Error: Could not connect to SMTP host.”
    [“From”]=>
    string(25) “**********@gmail.com”
    [“FromName”]=>
    string(26) “**** **** ********”
    [“Sender”]=>
    string(0) “”
    [“Subject”]=>
    string(52) “WP Mail SMTP: Test mail to **********@yahoo.co.uk”
    [“Body”]=>
    string(68) “This is a test email generated by the WP Mail SMTP WordPress plugin.”
    [“AltBody”]=>
    string(0) “”
    [“WordWrap”]=>
    int(0)
    [“Mailer”]=>
    string(4) “smtp”
    [“Sendmail”]=>
    string(18) “/usr/sbin/sendmail”
    [“PluginDir”]=>
    string(0) “”
    [“Version”]=>
    string(5) “2.0.4”
    [“ConfirmReadingTo”]=>
    string(0) “”
    [“Hostname”]=>
    string(0) “”
    [“MessageID”]=>
    string(0) “”
    [“Host”]=>
    string(14) “smtp.gmail.com”
    [“Port”]=>
    string(3) “465”
    [“Helo”]=>
    string(0) “”
    [“SMTPSecure”]=>
    string(3) “tls”
    [“SMTPAuth”]=>
    bool(true)
    [“Username”]=>
    string(24) “**********@gmail.com”
    [“Password”]=>
    string(8) “********”
    [“Timeout”]=>
    int(10)
    [“SMTPDebug”]=>
    int(2)
    [“SMTPKeepAlive”]=>
    bool(false)
    [“SingleTo”]=>
    bool(false)
    [“smtp”]=>
    object(SMTP)#150 (7) {
    [“SMTP_PORT”]=>
    int(25)
    [“CRLF”]=>
    string(2) “

    [“do_debug”]=>
    int(2)
    [“do_verp”]=>
    bool(false)
    [“smtp_conn”]=>
    bool(false)
    [“error”]=>
    array(3) {
    [“error”]=>
    string(27) “Failed to connect to server”
    [“errno”]=>
    int(110)
    [“errstr”]=>
    string(20) “Connection timed out”
    }
    [“helo_rply”]=>
    NULL
    }
    [“to”]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(25) “************@yahoo.co.uk”
    [1]=>
    string(0) “”
    }
    }
    [“cc”]=>
    array(0) {
    }
    [“bcc”]=>
    array(0) {
    }
    [“ReplyTo”]=>
    array(0) {
    }
    [“attachment”]=>
    array(0) {
    }
    [“CustomHeader”]=>
    array(0) {
    }
    [“message_type”]=>
    string(5) “plain”
    [“boundary”]=>
    array(2) {
    [1]=>
    string(35) “b1_b2e001f82c645670bc5aab9c062fcfcb”
    [2]=>
    string(35) “b2_b2e001f82c645670bc5aab9c062fcfcb”
    }
    [“language”]=>
    array(13) {
    [“mailer_not_supported”]=>
    string(25) ” mailer is not supported.”
    [“provide_address”]=>
    string(55) “You must provide at least one mailer is not supported.”
    [“execute”]=>
    string(19) “Could not execute: “
    [“instantiate”]=>
    string(36) “Could not instantiate mail function.”
    [“authenticate”]=>
    string(35) “SMTP Error: Could not authenticate.”
    [“from_failed”]=>
    string(35) “The following From address failed: “
    [“data_not_accepted”]=>
    string(30) “SMTP Error: Data not accepted.”
    [“recipients_failed”]=>
    string(56) “SMTP Error: The following SMTP Error: Data not accepted.”
    [“connect_host”]=>
    string(43) “SMTP Error: Could not connect to SMTP host.”
    [“file_access”]=>
    string(23) “Could not access file: “
    [“file_open”]=>
    string(33) “File Error: Could not open file: “
    [“encoding”]=>
    string(18) “Unknown encoding: “
    [“signing”]=>
    string(15) “Signing Error: “
    }
    [“error_count”]=>
    int(1)
    [“LE”]=>
    string(1) “

    [“sign_cert_file”]=>
    string(0) “”
    [“sign_key_file”]=>
    string(0) “”
    [“sign_key_pass”]=>
    string(0) “”
    }

    The SMTP debugging output is shown below:

    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

Viewing 4 replies - 1 through 4 (of 4 total)
  • This is the most commonly asked question on the plugin support page. It’s an issue with PHP settings around fopen().

    I fixed it, it just required the port 465 (for gmail) opening on the servers firewall.
    If anyone else has this issue then I would recommend speaking to your host.

    Badly im using Google Apps and it seem not working on my meo.vn. May it be because of host because the previous host worked?

    @binh: It could be an issue with your host either blocking ports or not allowing fopen() to connect to remote ports in PHP. I recommend speaking to your host as a first step.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WP Mail SMTP] SMTP -> ERROR: Failed to connect to server: Connection timed out (110)’ is closed to new replies.