Support » Plugins and Hacks » WP-LESS » [Plugin: WP-LESS] Trying to compile Twitter Bootstrap

  • Resolved syndrael

    (@syndrael)


    Hello,
    I’m trying to compile Twitter Bootstrap in LESS mode.
    I get a parse error in mixins.less, it’s due to the second line

    .spanX (@index) when (@index > 0) {
          (~".span@{index}") { .span(@index); }
          .spanX(@index - 1);
        }

    I think the problem comes from @{index}
    After commenting this line (for testing), the same behaviour appears for the same syntax.
    Could you help me ?
    Best regards from Paris, France.
    S.

    http://wordpress.org/extend/plugins/wp-less/

Viewing 3 replies - 1 through 3 (of 3 total)
  • In http://lesscss.org/#-mixins we can read
    String interpolation
    Variables can be embeded inside strings in a similar way to ruby or PHP, with the @{name} construct:

    @base-url: "http://assets.fnord.com";
    background-image: url("@{base-url}/images/bg.png");

    Is the feature supported by WP-Less ?
    Best regards
    S.

    Or may be escaping string is the problem…
    (~“.span@{index}”)
    S.

    I’ve found something interesting..
    WP-Less is based on lessphp.. but the plugin include lessphp v0.3.1.
    By changing it by lessphp v0.3.5 (download page), there is no more error message.
    I don’t say that every is ok to add Twitter Bootstrap LESS version in WordPress, but my investigations are going on..

    Closed topic for me.

    Best regards

    S.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP-LESS] Trying to compile Twitter Bootstrap’ is closed to new replies.