WordPress.org

Support

Support » Plugins and Hacks » WP jQuery Lightbox » [Plugin: WP jQuery Lightbox] jQuery Lightbox not working

[Plugin: WP jQuery Lightbox] jQuery Lightbox not working

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author ulfben

    @ulfben

    From the documentation;

    [gallery link="file"]

    Note the link=”file” – this is crucial! By default the gallery will link your humbnails to a page displaying your image. With link=”file” the thumbnails links directly to the image files – allowing Lightbox to function.

    Thanks so much for your reply. Love your plugin, I just hope I can get it working for me.

    I do understand that the shortcode link must =”file”.

    All of my links look like this:
    [gallery link="file" orderby="title" columns="4"]

    Any other ideas that I might try?

    Plugin Author ulfben

    @ulfben

    Your site spits out a few (5) JavaScript exceptions, so I’m pretty confused as to why anything works at all. 🙂

    Disable your plugins. Try the lightbox on it’s own. Enable the rest one after another until something breaks. Remove that plugin from your site.

    Good luck.

    Will do. Thank you so much. I will post my results when or if I figure it out.

    Out of curiosity, how do I test my site to see what exceptions are occurring?

    Thanks for your suggestions, I disabled all plugins and tried jQuery Lightbox on it’s own. I also refreshed the page and tried multiple browsers. No lightbox effect appears. The link goes directly to the image file. 🙁

    Does there need to be some kind of script in the header for this to work?

    Tried it with unaltered Twenty Eleven theme and it did not work, but it DID work with the WordPress Default (v. 1.6 based on Kubrick.) All other plugins were running.

    Plugin Author ulfben

    @ulfben

    Tried it with unaltered Twenty Eleven theme and it did not work

    I’m not going to say this is impossible. But it is. 🙂

    All other plugins were running.

    Ergo; it wasn’t unaltered. 😛

    Make sure your theme calls wp_head() and wp_footer() correctly. More info at the bottom of this page.

    Thanks again for your continued help!

    I deleted the twenty eleven theme and then re-downloaded it just to be sure it was in fact free of any modifications and tried again. I eventually found that the conflict was with a plugin called “Twenty Eleven Theme Extensions.” Which enables me to have a sidebar on single posts pages.

    I still have one issue I’d like to solve: Lightbox is now working as expected with single posts, but it is not working for galleries displayed in “blog view” – when scrolling through multiple posts. These sill link to the file.

    Thanks so much for your help but I think I’m giving up at this point.

    I disabled the wenty Eleven Theme Extensions plugin and hand coded the sidebar back into single posts and pages which broke WP jQuery Lightbox for some reason. I love the plugin but since my theme isn’t playing well it’s time to move on. I think I am going explore using flickr- or picasa-based galleries now.

    Thanks again for being one of the few developers who actively tries to help users on the forums!

    Plugin Author ulfben

    @ulfben

    Thanks for reporting back! Luckily there’s a metric ton of *boxes out there, so I’m sure you’ll find something that work better for you.

    Have a nice week!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WP jQuery Lightbox] jQuery Lightbox not working’ is closed to new replies.
Skip to toolbar