WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP ImageTagger] Not working with WP 2.9.1?

[Resolved] [Plugin: WP ImageTagger] Not working with WP 2.9.1?

  • I’m currently working on my new website and your extension will really help me 🙂
    Trying to activate it, I’ve got the same error every time :
    Parse error: syntax error, unexpected ‘=’, expecting ‘)’ in ../wp-content/plugins/wp-imagetagger/imagetagger-lib.php on line 299

    I desactivated each extension in order to see if one of these was the problem, but it did not change anything.

    Did you test it with my WP version?

    Merci par avance, et bonjour de Lyon 😉

    http://wordpress.org/extend/plugins/wp-imagetagger/

Viewing 15 replies - 1 through 15 (of 23 total)
  • I am checking and will let you know.

    Bonjour de Grenoble

    I might have found the reason, while I am not 100% sure … Where is your site hosted ? Which PHP version ?
    Bruno

    Another question : do you face the same behaviour using ImageTagger 1.0 ? Did you experience it with V1.1 first ?

    … and did you check you have already images or photos available in your posts ? Pls give a try to V1.2.

    I checked with the 1.0 and 1.1. Have images in my posts. My website is hosted with OVH. PHP version : 5.2.11
    Check with 1.2, there’s always an error when I try to activate it :

    Parse error: syntax error, unexpected ‘=’, expecting ‘)’ in /homez.28/site/dev/wp-content/plugins/wp-imagetagger/imagetagger-lib.php on line 342

    Thank you 🙂

    Bizarre …

    This line is a function definition :

    function imgt_get_images_untagged(&$reason=0) {

    Maybe the server disallows compact byref argument initialization. I am going to slightly change it in version 1.3, please try downloading the latest 1.3 in 15 minutes.

    Bruno

    Arf…

    Parse error: syntax error, unexpected ‘=’, expecting ‘)’ in /homez.28/site/dev/wp-content/plugins/wp-imagetagger/imagetagger-lib.php on line 340

    I don’t think you got the last release … there is no more “=” in line 340.

    Please open imagetagger-lib.php and copy/paste line 340 so that I am sure.

    Then reload 1.3, I guess you downloaded it before the changes were reflected by the repository manager.

    You’re right, it was not really the 1.3…
    Thank you, no more error message during the activation!
    I can test it now 😉

    Erk… another problem in the admin area. For each tag listed, I’ve got this message :

    Warning: in_array() [function.in-array]: Wrong datatype for first argument in /homez.28/site/dev/wp-content/plugins/wp-imagetagger/imagetagger-admin.php on line 171

    Hébé … pas sympa ce serveur. Je regarde ce soir.

    Apart from this warning, please confirm the functionality is OK and that you don’t get anymore errors.

    I put the function in my sidebar, when I check a tag, the next page displays this error :

    Thème recherché :
    Fatal error: Call to undefined function: array_uintersect() in /homez.28/site/dev/wp-content/plugins/wp-imagetagger/imagetagger-lib.php on line 246

    Concerning the last message :

    Fatal error: Call to undefined function: array_uintersect() in /homez.28/site/dev/wp-content/plugins/wp-imagetagger/imagetagger-lib.php on line 246

    I would expect to get this style of message with a server running PHP4.

    I really wonder how can this happen. array_uintersect is a standard PHP function starting from PHP5. Referring to your previous messages, I understand you are in PHP 5.2.11 (pls confirm). Therefore this message is a non sense.

    Is your web hosting mutualized, or is that a dedicated server ?

    Pls confirm this behaviour with the latest development release.

    Thx.

    Hum, I’m sorry, one of my other websites is under PHP 5.2.11, so I thought my dev one too, but it’s 4.4.9. My apologizes.
    I’m under a mutualized web hosting. I check the latest release.

    So, now I’ve got this lovely message 😉
    Le serveur hébergeant le blog doit être équipé au minimum de la version PHP 5 pour pouvoir faire fonctionner le plugin ImageTagger.
    La version 4.4.9 a été détectée sur ce serveur.

    (je développe la nouvelle mouture de ce site sur mon serveur mutualisé, mais ayant acheté un dédié depuis quelques jours, je vais le migrer avant de publier la nouvelle version – je pensais le faire après avoir fini le travail, mais à la vue des problèmes rencontrés…)

    So thank you for your very fast answers 🙂 I’ll let you know if I find more “problems”.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] [Plugin: WP ImageTagger] Not working with WP 2.9.1?’ is closed to new replies.
Skip to toolbar