WordPress.org

Ready to get started?Download WordPress

Forums

WP htaccess Control
Google Denied Access - 403 error - Needs Login Credentials (9 posts)

  1. Grace Massa Langlois
    Member
    Posted 2 years ago #

    Good Morning

    My developer processed the update for the plugin and then Google was denied access to crawling my pages and it is blocking urls's. Page wp-app.php/service is returning a 403 requiring log in and password, when these are not provided it returns a 403 error code. It appears that all of my post pages have dropped from search, in some cases my home page is appearing. Could you please advise if there is something we should have been doing to the settings. I spoke with my hosting provider today and apparently changes were made to the wp-app.php files. I apologize if I am not providing the appropriate details but I am not at all technically inclined.

    I would appreciate any assistance.

    Thank you!

    http://wordpress.org/extend/plugins/wp-htaccess-control/

  2. antonioandra.de
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Mia,

    the issue you describe is probably not related to WP htaccess Control but what version of the plugin are you using at the moment?

    Also, have you tried deactivating all plugins and see if things work?

    I spoke with my hosting provider today and apparently changes were made to the wp-app.php files

    Again, I don't see how this could be caused by WP htaccess Control. Could your website have been hacked into?

    It's quite hard to further debug without digging in your current setup...

    Let me know how it goes.

    António

  3. Grace Massa Langlois
    Member
    Posted 2 years ago #

    Hi Antonio

    I am not sure what's going on but yesterday my hosting provider said the htaccess file was changed and they led me to believe this was there and it probably shouldn't be"

    "calling up interface module for Apache Server"

    I'm sorry I am not at all versed on the technical side of my site. I hire someone to take care of everything tech related. I don't even know how to update plugins, again I hire someone. All I know is something changed after the plugin was updated.

    Hoping someone can help me find the issue. I went as far as asking Google for a site reconsideration an they've replied with there was no manual penalization but the problem could be the Server Architecture (not sure what that means) and site access.

    If you could shed any light I would appreciate it.

    My site name is http://gracessweetlife.com

    Grace

  4. Grace Massa Langlois
    Member
    Posted 2 years ago #

    oops forgot to let you know I have version 3.2.1

  5. antonioandra.de
    Member
    Plugin Author

    Posted 2 years ago #

    Grace,

    I understand you're facing some kind of issue but your description of it doesn't enable me to help you any more at this point. To be honest I don't think either of us clearly understand what the problem consists of.

    I'd still suggest updating WordPress and the plugin to their latest versions but I don't see why that would solve anything.

    Again, to help you any further I'd need to look into your setup. If you feel like it do get in touch by email (you can find it at the bottom of my homepage).

    António

  6. Grace Massa Langlois
    Member
    Posted 2 years ago #

    Thank you Antonio and I completely agree I haven't a clue what the problem is and I apologize that I can not communicate the issue properly. I will reach out via email - thank you!

  7. seanpearse
    Member
    Posted 2 years ago #

    Hi Grace & Antonio,

    Have you had any luck resolving this issue? I have had the same problem and I didn't want to disable all my plugins one by one to get to the bottom of it so I disallowed access to it from my robots.txt. I thought this had done the trick as it got rid of the error in Webmaster Tools but my home page hasn't returned to the SERPs yet. I done this over a month ago.

    Any help with the matter is much appreciated.

    Thanks,

    Sean P.

  8. Rick Cano
    Member
    Posted 2 years ago #

    I know this may sound like a "too easy to work" solution.....but I simply turned off the Remote Publishing setting in the Writing Options within the Dashboard.

    I did this over 3 years ago and I've not seen that error come up at all for my site and I've not lost any page rank or homepage visibility.

    Oh I'm sure you can modify your robots.txt file, or your .htaccess file and even modify the url but I wouldn't suggest any of those.

    What did I do? I disabled it because its "optional" and unless your going to use a desktop remote publishing client its a waste of time having it toggled on. I then for the sake of crawling errors set up a "redirect" by using a Redirection tool and then redirected the url to my homepage.

    However, I'm not suggesting you do any of these...I just wanted to share what has worked for me and I'm not seeing any issues.

    Thanks again

  9. jasonbunnell
    Member
    Posted 2 years ago #

    rcano,

    I am running 3.4.2. I am getting the same crawl error for
    wp-app.php/service . I tried what you suggested to disable the remote publishing option. These seem to be disabled by default.

    Has anyone else found a solution for this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic