[Plugin: WP-Hashcash] Strange problem, can't get to the Options Screen (5 posts)

  1. Gene53
    Posted 5 years ago #


    I installed this plugin and when I activate it, I don't get the Options Screen in settings but the sidebar widget can be activated.

    I tried accessing the options by going directly to the page (http://sitename.com/wp-admin/options-general.php?page=wp-hashcash.php and I get "You do not have sufficient permissions to access this page".

    Any ideas on how to correct this?

    WP 2.9.2
    BP 1.2.3


  2. caneblu
    Posted 5 years ago #

    same problem here, same config WP and BP.

  3. rhertzog
    Posted 5 years ago #

    Same problem here with wordpress 3.0 with multisite enabled.

  4. Arturo

    Posted 5 years ago #

    same problem with wp 2.9.2 and bp

    any help?

  5. stirlyn
    Posted 5 years ago #

    I changed all the occurences of is_site_admin to is_admin (or is_super_admin if you're running multisites)
    Then on line 172 where it lists
    add_submenu_page('wpmu-admin.php', __('WordPress Hashcash'), __('WordPress Hashcash'), 'manage_options', 'wphc_admin', 'wphc_admin_options');

    I changed this to
    add_submenu_page('options-general.php', __('WordPress Hashcash'), __('WordPress Hashcash'), 'manage_options', 'wphc_admin', 'wphc_admin_options');

    and it now shows under the Settings menu.
    This is for 3.x

Topic Closed

This topic has been closed to new replies.

About this Topic