WordPress.org

Forums

WP Geo Big Map
Error on Page Load (8 posts)

  1. xongooli
    Member
    Posted 4 years ago #

    I'm running wordpress 3.4.1

    After installing the plugin and adding the short code to a new page I get the error - "Can't display big map because GoogleMaps is not available. This normally means you haven't yet installed WP Geo, or that you haven't activated it with the Google API Key".

    I also get an error on the page itself saying "Big Map can't be displayed, possibly because JavaScript is turned off."

    Is an API key required?

    Here's the page -

    http://authenticluxurytravel.elizabethhansen.net/posts-by-location

    Any help would be much appreciated

    http://wordpress.org/extend/plugins/wp-geo-big-map/

  2. mbernasocchi
    Member
    Posted 4 years ago #

    how did you solve this? (I saw on your site that it works now) thanks

  3. proba1
    Member
    Posted 4 years ago #

    hi,

    I am also interested in the solution please

  4. mbernasocchi
    Member
    Posted 4 years ago #

    I solved by activating show wp-geo on pages (wp-admin/options-general.php?page=wp-geo/includes/wp-geo.php)
    ciao

  5. JReders
    Member
    Posted 3 years ago #

    Hi,
    I have se same problem and im looking for help please ;)
    mbernasocchi, what do you mean by "ctivating show wp-geo on pages (wp-admin/options-general.php?page=wp-geo/includes/wp-geo.php)"
    Can explain me a little more please.

    Thanks

  6. JReders
    Member
    Posted 3 years ago #

    My problem was that im using Better WP security.
    I had to uncheck the "Display random version number to all non-administrative users", tweak (point 19 in the dashboard).
    Now everything is working, Thanks to Bernie's help ;)

  7. ebrithil
    Member
    Posted 3 years ago #

    I get the same error, could you please tell me how you fixed this. I looked under general settings but there was no show wp-geo option. Other than this I'm not using Better WP security. Could it be that my site is on a multisite?

  8. JReders
    Member
    Posted 3 years ago #

    Hey,
    I had a conflict with WP Better security.
    So, if you're not using it i can't help you...
    If you are using this plugin too, in the tweaks, uncheck "Display random version number to all non-administrative users". It will change the status of #19 in the WP better security dashboard. and the big map will work.
    You may use another plugin witch could create a conflict with this plugin or more globally with the Google API.
    Hope it helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Geo Big Map
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.