Support » Plugins and Hacks » Removing event start times in WP FullCalendar

Removing event start times in WP FullCalendar

Viewing 15 replies - 1 through 15 (of 16 total)
  • On this website that I created several weeks ago, there is no times appearing on my events listing: http://www.shamaniclightwork.org/calendar/. This uses a .06 version of WP-Fullcalendar.

    This newer website http://shaktionline.org/ uses the .07 version, which I suppose is what is creating the default 12a times, even for all-day events, which I really do not want to appear. (Right now I’m using an asterisk so people can even understand what this 12a means.) So if this time listing changed in the newer version, if there is no other way to eliminate these starting times in vers. .07, is there some way I can download .06 or copy it from my older site and bring it in the newer site?


    Hi suerama,

    This was driving me crazy, too, but I found an answer. You’ll have to do some file editing. Follow this path on your WP installation:

    wp-content >> plugins >> wp-fullcalendar >> includes >> js

    The file you want to edit is main.js. Search for the following string:


    There should be only one occurrence in the file. Verify this before proceeding. Then delete:


    so that the new string reads:


    This solved the problem for me, and so far it hasn’t caused any problems.

    For safety’s sake, I copied the main.js file to my local computer and then renamed the file on the server to main-old.js. I then edited the local file and copied it back to the server.

    Hope this helps!

    Hi linuxguy,

    Thanks for the tip! That works fine with one-day events. However, when the event spans a second line in the calendar the date does show up in the second mention. Any additional tips to offer? This kind of code is gibberish for me!

    Thanks again!

    Hi Sue,

    I’m afraid that’s all I’ve got. The change seems to be working for me on multi-day events, too.

    Hopefully, the devs will work these changes into the next release.

    God bless!

    Useful hack. I hope the next version gives the option to display times or not. It looks silly to have all day events showing a 12 a.m. time.

    to remove completely:


    But in which file ?

    Just place it in your theme’s style.css

    It works, wonderful !

    Plugin Author Marcus


    NetWebLogic Support

    fyi, this now can be set from your WPFC settings page, i.e. no time = blank setting

    Very helpful.
    Thank you all!

    I just installed the latest update and my times on the Full Calendar have disappeared. Any idea why? I’ve re-installed my backup DB and files right before the update 2 times and same result both times after the WP-FC update. I checked in the settings and my time format is NOT blank.

    Thank you and regards on a great plugin.

    @dwbjd have you checked Events -> Settings -> WP Full Calendar -> Event Title Format? In here , you can use Events Manager Placeholders, like ‘#_24HSTARTTIME #_EVENTNAME’.

    Plugin Author Marcus


    NetWebLogic Support

    @dwbjd, assuing you’re using Events Manager, there is a bug to be fixed in 0.8.2 coming soon

    Thank you so much for updating this. Thought I was missing something. Yes I am using the Event Manager as well. Fantastic plugins sir! Will look for the update. Thank you so much.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Removing event start times in WP FullCalendar’ is closed to new replies.