WordPress.org

Support

Support » Plugins and Hacks » WP Forum Server » [Plugin: WP Forum Server] Won't activate (v. 1.7.5)

[Plugin: WP Forum Server] Won't activate (v. 1.7.5)

Viewing 1 replies (of 1 total)
  • I also had trouble getting the plug-in to activate, after installing it. Some information that may help:

    • Attempts to activate the plug-in from the WordPress plug-ins administration page page, resulted in a “connection closed by remote server” error displayed by my browser (Opera).
    • The activation worked once I set WP_DEBUG to FALSE. On that note, running the plug-in with debug mode enabled resulted in a lot of PHP warning and error reports. This suggests that the plug-in has only been tested in release mode but not debug mode.
    • My plug-ins directory and its containing content directory are not in the default locations (ABSPATH . “wp-content/plugins/”). This plug-in’s code seems to make some assumptions about directory paths, rather than using the WordPress defined constants such as WP_PLUGIN_DIR. An example of this (for version 1.7.5) is at line 683 of wpf.class.php:

      $plugin_data = implode('', file(ABSPATH."wp-content/plugins/".WPFPLUGIN."/wpf-main.php"));

    Until the directory problems are resolved, I’m unable to use this plug-in on my web site.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: WP Forum Server] Won't activate (v. 1.7.5)’ is closed to new replies.
Skip to toolbar