WordPress.org

Ready to get started?Download WordPress

Forums

WP-Filebase Download Manager
[resolved] WP-Filebase filename length limit (6 posts)

  1. john@chalkandtalk.co.uk
    Member
    Posted 2 years ago #

    I am working with long filenames and I see the filename length is set at vechar(127) this means my files don't display the correct logo and sometimes do not download properly.

    I have changed the database set up for file_name to vechar(255) in a local test bed site and it seems to work fine but can this cause problems with a live site? - if so what kind of problems and why is it set so short in the first place?

    Thanks

    http://wordpress.org/extend/plugins/wp-filebase/

  2. Fabian
    Member
    Plugin Author

    Posted 2 years ago #

    This should not cause any problems. Length is only limited by the database.

  3. john@chalkandtalk.co.uk
    Member
    Posted 2 years ago #

    Thanks - done it and it works fine. A great plugin - I tried so many file handling plugins and this is by FAR the best. Will be making a donation when I get paid!

    ATB

  4. CMM Concepts
    Member
    Posted 2 years ago #

    Would someone please expand on exactly what "changed the database set up for file_name to vechar(255)" means? based on fabifott's response, it sounds like this is done somewhere/somehow in the actual database? Like through PHP MyAdmin?

    I'm not very knowledgeable about a lot of the backend stuff, but I'm great at following clear directions. :)

    Thank you very much.

  5. CMM Concepts
    Member
    Posted 2 years ago #

    I think I'm close, but it didn't quite work.

    Using PHP MyAdmin, I selected the correct database and then in wpfb_files under file_name clicked "Change" and saved this change there.

    I deleted the original files that didn't sync properly from the WP-Filebase Admin in WordPress, but it still synced them again with truncated names.

    I deleted ALL FILES, from the WP side, and synced again, and it only imported the four files with truncated file names, still truncated.

  6. john@chalkandtalk.co.uk
    Member
    Posted 2 years ago #

    Hi CMM Concepts

    Yes in phpmyadmin find the table wp_wpfb_files click the second buton along with the roll over 'structure' in this table find the field file_name and click the 'change' button and change Length/Values to whatever - I set mine to 255 and remember to click save.

    I deleted all the old files by ftp - synced and then also deleted the old database entries using the WP-Filebase interface option to do that - uploaded the new files by ftp and synced again. All the long file names work fine now.

    ATB

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic