WordPress.org

Ready to get started?Download WordPress

Forums

WP-FFPC
[resolved] Backend status: down? (10 posts)

  1. hausinteractive
    Member
    Posted 2 years ago #

    Hi.

    Using:

    - FFPC 0.4.1
    - WordPress 3.2.1
    - apache mod_php
    - memcached 1.4.10

    CLI suggests that memcache is running:

    telnet localhost 11211
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    stats
    STAT pid 23002
    STAT uptime 15264076
    STAT time 1345821310
    STAT version 1.4.10
    STAT libevent 1.4.12-stable
    STAT pointer_size 32
    STAT rusage_user 1434.026495
    STAT rusage_system 9286.831125
    STAT curr_connections 5

    etc...

    I have added the necessary define('WP_CACHE',true); to the config file and set the plugin settings to:

    hostname: localhost
    port: 11211

    ...but the "Settings for memecached backend" state:

    Backend status: DOWN.

    Is this a false positive or is something else wrong?

    I've turned on "Enable debug mode" and "Enable syslog messages" but am not sure where to gather the results.

    Thanks in advance.

    http://wordpress.org/extend/plugins/wp-ffpc/

  2. hausinteractive
    Member
    Posted 2 years ago #

    Update: Just downloaded and ran a copy of http://code.google.com/p/memcache-top/ (which is kind of cool, btw) and while hammering on a site running FFPC I did not see the stats do much of anything.

    This leads me to suspect that the Backend status: DOWN message is accurate.

    If I'm right then the question becomes: Why is the plugin seeing memcache as down when it is not?

  3. petermolnar
    Member
    Plugin Author

    Posted 2 years ago #

    Hi hausinteractive,

    Which PHP memcache module are you using: Memcache or Memcached?
    Could you please send me the config of the PHP module as well?

  4. hausinteractive
    Member
    Posted 2 years ago #

    Hi Peter,

    We are running memcached

    I am emailing the config to the address listed on your website.

    Cheers.

    --
    Aaron

  5. clearpointccs
    Member
    Posted 2 years ago #

    I am having this same issue.
    I'm using Nginx, and copy-pasted your example config included with the plugin, and also reinstalled memcached and the memcache extension using the instructions here. I can interact with memcached on the CLI, and php info shows that the memcache extension is loaded, the the WP-FFPC plugin shows that it's down.

    I'm happy to send you any files at all which can help diagnose the issue!

  6. petermolnar
    Member
    Plugin Author

    Posted 1 year ago #

    I think this is related to a bug in the memcache plugin and I currently unable to solve it; please keep posting anything related this bug that'd help.

  7. petermolnar
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I've completely rewritten the memcached backend check in version 0.6.1
    Could you please send me the results with that version?

    Cheers,
    Peter

  8. hausinteractive
    Member
    Posted 1 year ago #

    Hi Peter,

    I've downloaded 0.6.1 and when saving the settings I get this:

    ERROR: Memcached cache backend activated but no PHP memcached extension was found.

    I see this in our server error logs:

    [Fri Mar 08 08:22:26 2013] [error] PHP Fatal error: Call to a member function flush() on a non-object in /directory/wp-content/plugins/wp-ffpc/wp-ffpc-common.php on line 196, referer: http://domain.com/wp-admin/options-general.php?page=wp-ffpcoptions

    Additionally, I see this message in the settings:

    Backend status: 127.0.0.1:11212 => unknown, please try re-saving settings!

    Nothing has changed in our server software from my first post but my test copy of WordPress is now 3.5.1 and our wordpress memcache instance is now on port 11212.

  9. petermolnar
    Member
    Plugin Author

    Posted 1 year ago #

    Hi hausinteractive,

    The message ERROR: Memcached cache backend activated but no PHP memcached extensio"n was found. comes gets displayed if the following happens:

    <?php if ( $this->options['cache_type'] == 'memcached' && !class_exists('Memcached') ) : ?>

    That means there's no Memcached class on the server. Please change to memcache mode as backend option or install PHP Memcached extension.
    You most probably has Memcache extension ( not the missing d at the end ).

  10. hausinteractive
    Member
    Posted 1 year ago #

    Strange, I swore we had memcached and yet there it is: working using the "memcache" option. I now see:

    Backend status:
    127.0.0.1:11212 => up & running

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic