Support » Plugin: WP Facebook Open Graph protocol » [Plugin: WP Facebook Open Graph protocol] Update 2.0.5 Breaks jQuery

Viewing 12 replies - 1 through 12 (of 12 total)
  • fergofer00

    (@fergofer00)

    Same thing happened to me, the panel is not working properly edit articles.

    devrimgumus

    (@devrimgumus)

    Theres a problem with 3.4.2. everyone having the same problem.

    Plugin Contributor Andrew Ryno

    (@andrewryno)

    2.0.5 didn’t change anything that would cause that breakage. Did jQuery break from WPFBOGP 2.0.4 to 2.0.5 or did you just update WordPress from 3.4.1 to 3.4.2?

    kandrews

    (@kandrews)

    No, I only updated the WPFBOGP. I had to revert back to the 2.0.4 version to get it back working.

    seriocomic

    (@seriocomic)

    +1 for this latest update breaking the admin…

    Rasmus

    (@rasmusbe)

    +1 on jQuery broken in 2.0.5.
    Had to revert

    heydavecole

    (@heydavecole)

    +1 on jQuery conflicts w 2.0.5

    adityaaguptaa

    (@adityaaguptaa)

    Any clue when would the update be out?

    Jason Newlin

    (@jasonnewlin)

    @andrew – so, after some debugging version 2.0.5 is NOT ‘breaking jQuery’, for me. But it is throwing a JS exception: Uncaught SyntaxError: Unexpected token ILLEGAL

    What it is doing is stripping out the backslash from ‘<\/script>’ tag, that lots of people have as part of their footer from html5-boilerplate.

    I tested version 2.0.4 and diff’ed the rendered output with version 2.0.5, and the only difference is stripping the backslash. I have NO idea why this would be happening.

    This is the entire line straight from html5-boilerplate (to load as a fallback if google fails):
    <script>window.jQuery || document.write('<script src="js/vendor/jquery-1.8.1.min.js"><\/script>')</script>

    Hope this helps.

    Desik

    (@desik)

    tidusuper91

    (@tidusuper91)

    Same issue here. Hope this will be solved soon. Where can i retrieve the previous version?

    Plugin Author Chuck Reynolds

    (@ryno267)

    2.0.6 pushed just now will fix… basically a rollback until we reassess the updates we tried to make – things got hairy fast and pushing a quick update was ill-conceived.

    working on a bigger rewrite of the plugin to do everything better as well as address these issues.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WP Facebook Open Graph protocol] Update 2.0.5 Breaks jQuery’ is closed to new replies.