Support » Plugin: WP Facebook Open Graph protocol » [Plugin: WP Facebook Open Graph protocol] It shows the photo only on "likes" and not on sh

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Chuck Reynolds

    (@ryno267)

    The plugin isn’t doing anything different – Facebook is typically buggy and never consistent so it’s on them. I see different stuff almost daily with the way it pulls OGP

    Yes indeed, facebook has many updates on it’s code. I have checked other WordPress sites and I post them normally and it shows the photo of the post. So what is it happening? How can you help me to fix this?

    Plugin Author Chuck Reynolds

    (@ryno267)

    The only thing that can be different is Facebook holds a cache of links. I don’t know for how long but that’s the only reason it would show different results than the debugger. Debugger shows non-cached data. The normal share on facebook.com isn’t far behind getting new data, but again – I don’t know how long they hold cache.

    Yeah, but the sites that I check and I am able to post their links on my wall and has the photo are fresh news. Why they are being shown to them but not me if this is the case?

    It still keeps not showing the photo of any post when you share it in the wall of any fb profile. I don’t think that is a problem of fb, something else must be going on…
    Maybe your plugin doesn’t support any of these below. Am I right?
    AdRotate
    All in One SEO Pack – Pro Version
    Better WP Security
    BM Custom Login
    CloudFlare
    Contact Form 7
    Easy Mashable Social Bar
    FeedBurner FeedSmith
    Google Analytics for WordPress
    JW Player Plugin for WordPress
    NextGEN Gallery
    Really Simple CAPTCHA
    Redirection
    registration-login
    Tabber Tabs Widget
    Top 10
    Twitter Blockquotes
    Wordpress Firewall 2
    Wordpress Popular Posts
    WordPress Related Posts
    WordSocial
    WP-Filebase
    WP-Optimize
    WP-PageNavi
    WP-reCAPTCHA
    WP-UserOnline
    AJAX Thumbnail Rebuild
    Google XML Sitemaps

    I’m having the same problem. By now i know that must be something with CloudFlare. I know because i don’t get this error when using a direct link.

    But i don’t know why is this happening and how to fix it… =/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP Facebook Open Graph protocol] It shows the photo only on "likes" and not on sh’ is closed to new replies.