Support » Plugins » [Plugin: WP Facebook Open Graph Protocol] Facebook debug tool 'og:title' error

  • Guys, I have tried everything I know to do to correct the following issue with no luck.

    When I try to Facebook share a post on my site some random characters are showing on the preview where the description line is supposed to be. After searching through many different forum threads, I finally think I narrowed the issue down to a particular plugin I am using: WP Facebook Open Graph Protocol.

    (I am using the plugin because it’s the only one that I know of that will force Facebook to use the same thumbnail with every post I share. All other plugins I have found only use a specified thumbnail if no other image is present, which is an obvious problem given that there are usually other images present. I love said plugin so I really need help sniffing out what’s causing it to act buggy.)

    Here is the error message that shows after I click “fetch new scrape information” using the Facebook debug tool: “Object Missing a Required Value Object at URL ‘http://fanjabs.com/blog/2014/12/31/jim-harbaugh-new-head-coach-michigan-wolverines/’ of type ‘website’ is invalid because a required property ‘og:title’ of type ‘string’ was not provided.”

    The message that shows when I click on “Show existing scrape information”: “Inferred Property–The ‘og:url’ property should be explicitly provided, even if a value can be inferred from other tags.
    Inferred Property–The ‘og:description’ property should be explicitly provided, even if a value can be inferred from other tags.”

    The plugin author has addressed this issue before, and it looks like the issue is usually related to his plugin competing with another plugin that pulls open graph meta info. I have tried disabling the SEO Yoast plugin and the WP Super Cache plugin, as they have been mentioned on a couple of threads as possibly being the issue. That being said, deactivating them has not worked. I checked SEO Yoast to make sure that the “Social” settings were all clear as not to compete with Open Graph Protocol plugin as the author suggested, which also didn’t work. The only thing that seems to fix the issue for a couple of minutes at a time, is to Clear the cache through WP Super Cache.

    Okay, so obviously I need to try something else, right? Next I thought it might be a theme issue, but I’m not finding anything that would point in that direction. I have checked the Hearder and Function files and there are no open graph tags listed, so I’m guessing that can’t be what’s possibly competing with OGP plugin.

    Last move left in my brain, I checked the OGP plugin to make sure that I had my app id listed in the required field correctly…no issue there, either.

    https://wordpress.org/plugins/wp-facebook-open-graph-protocol/

    Theme I am using: Parabola/Cryout Creations: http://www.cryoutcreations.eu/parabola

    Will list all of the plugins I am using upon request.

    The logical part of my brain is toast. Please help. Thanks in advance.

  • The topic ‘[Plugin: WP Facebook Open Graph Protocol] Facebook debug tool 'og:title' error’ is closed to new replies.