WordPress.org

Support

Support » Plugins and Hacks » WP Facebook Open Graph protocol » [Resolved] [Plugin: WP Facebook Open Graph protocol] Description blank using All In One SEO and CDN

[Resolved] [Plugin: WP Facebook Open Graph protocol] Description blank using All In One SEO and CDN

  • Hello –

    I just installed your plugin, and I think it will do 100% of what I need it to do, and essentially it’s just listing out the title,url, image & description

    The description isn’t showing up on any pages….

    I’m using All In One SEO plugin and Amazon Cloudfront CDN on a Multisite blog…

    the description is showing in the meta description, but not the og:description…

    I have a social plugin, but there is an unchecked tick mark for adding OGP ( ie, I have it turned off, in favor of using your plugin because it will work with AIO )

    So I’m a bit stumped on what I’m doing wrong to get the og:description working… something with CDN? with Multisite? or just general user error?

    Thanks

    Matt

    PS – on the homepage, no image is selected, and it tries to use the default image, rather than pulling from one of the posts…

    http://wordpress.org/extend/plugins/wp-facebook-open-graph-protocol/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi there,

    Thanks for a great plugin. Rather than create yet another topic on missing descriptions I’m adding to this one. My problem is similar, except that I’m not using CDN. However, I do have a “tagline” description specified in WordPress General Settings, and I have All in One SEO settings with a separate description specified for the home page.

    Problem = on the home page only, the home page description meta displayed by AiOSEO isn’t pulling through to the FB og:description. (the FB og:description pulls through fine on interior pages and posts)

    URL=http://novofoundation.org/

    I noticed AiOSEO is creating a duplicate set of meta info in my <head> area, so I commented out the top description meta (which was blank) to avoid conflicts. There still is a meta description listed in my page source under AiOSEO.

    Just for kicks, I tried modifying my original meta description at the very top in header.php, which was recognized by Facebook og:description, but it then used that as the description for every interior page/post as well. (not what we want)

    Currently, when I post a link to the novofoundation.org home page on Facebook, it grabs a random post excerpt for the description instead of the correct one (either WP Gen’l Settings or AiOSEO–they’re both the same description so I don’t care which as long as it’s correct)

    In my header.php file, I don’t have any php within the meta description tag to auto-generate anything. It’s just blank.

    Any ideas? Thanks very much for your help!

    Plugin Author Chuck Reynolds

    @ryno267

    I think there’s a bug with it.. i’ll be updating that part of the filter tomorrow (well today but it’s 4am here so later today)

    Plugin Author Chuck Reynolds

    @ryno267

    eh i’m not that tired yet… just pushed 2.0.7 to repo. should fix.

    Hi Chuck,

    I am using All in one SEO and I have the same problem.
    og:description is blank. I have 2.0.7 installed.
    Excellent work though 😉

    Hugo

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: WP Facebook Open Graph protocol] Description blank using All In One SEO and CDN’ is closed to new replies.
Skip to toolbar