Support » Plugin: WP Editor » [Plugin: WP Editor] Post/Page Editor does not load

  • Resolved sdaveCL

    (@sdavecl)


    Just as the title says, using the most recent versions of WordPress 3.4.1 and WP Editor Plugin 1.1.0.1, the highlighted editor does not load for posts and pages.

    All it is doing now is removing the bar with bold, italic, ul, ol etc tag buttons on it.

    I have tried deactivating/reactivating the plugin, flushing my browser cache, turning the post/page highlighter off and on again. None have worked.

    http://wordpress.org/extend/plugins/wp-editor/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author benjaminprojas

    (@benjaminprojas)

    sdaveCL,

    Do you have any errors in your console? What browser are you using?

    I’ve tried Chrome, Firefox, Opera, IE 9, editor does not appear.

    This error pops up in both Chrome and Firefox consoles (haven’t tested others)

    “NetworkError: 404 Not Found – http://example.net/example_wp/wp-content/themes/business-lite/core/library/js/jquery-custom.js?ver=3.4.1

    It’s being called for by line 40 of wp-admin/post.php

    I looked through a few old versions of the Business Lite theme that I’m using and none of them have that file. It is not present anywhere on my server.

    Could that have something to do with it? There aren’t any other errors in console.

    Plugin Author benjaminprojas

    (@benjaminprojas)

    sdaveCL,

    That may have something to do with it, but I doubt it. To fully test, I would activate one of the default WordPress themes (i.e. TwentyEleven) and see if the error continues to happen.

    Alternatively, disable all your plugins except for WP Editor and see if the error still occurs.

    Nope, the missing jquery-custom.js file wasn’t the culprit.

    I went back and installed WP Editor on the development site and it just works. Same plugins, same theme. Works on the development site, but not on the live site. They’re even hosted by the same web host, albeit on different servers.

    Tried switching back to TwentyEleven theme, deactivating all the plugins on the live site. Didn’t work. Tried deleting and reinstalling WP Editor. Nope.

    Thanks very much for the suggestions.

    Plugin Author benjaminprojas

    (@benjaminprojas)

    sdaveCL,

    If you can’t duplicate this on your identical development server, I am not sure there is much I can do to further troubleshoot. I am not able to duplicate this locally either.

    Understandable. Thanks for all your help. I’ll report back if I figure out what the problem is.

    Plugin Author benjaminprojas

    (@benjaminprojas)

    sDaveCL,

    I have released a new version of WP Editor. Can you upgrade (1.1.0.2) and see if it makes any difference whether or not the editor loads?

    No luck with 1.1.0.2. Thanks though.

    Even tried re-installing WordPress. Something strange going on with my setup on this client’s site.

    The plugin also works fine on my personal website, so I don’t suspect there is anything wrong with your plugin.

    I figured it out!

    I had my profile set to “Disable visual editor when writing.”

    If I turn that off, the numbering and syntax highlighting works just fine. The button bar also loads.

    It’s just when the visual editor is disabled in the WordPress profile settings that the HTML editor doesn’t load properly on this site.

    Plugin Author benjaminprojas

    (@benjaminprojas)

    sdaveCL,

    I was able to duplicate the issue locally and provided a fix in the version I just released. Can you update to 1.1.0.3 and test again?

    Yes, indeed. It works now (1.1.0.3) even with the visual editor disabled. Thanks very much for all your help.

    Plugin Author benjaminprojas

    (@benjaminprojas)

    Awesome! glad to help!

    -Benjamin

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WP Editor] Post/Page Editor does not load’ is closed to new replies.