WordPress.org

Forums

WP eCommerce
[Plugin: WP e-Commerce] WP-eC 3.8.8.5 - Product details at the top of regular blog posts. (6 posts)

  1. Jon Hardison
    Member
    Posted 2 years ago #

    We're using Elegant Themes' Boutique v1.6, WP 3.4.1 and WP-eC 3.8.8.5. Everything with the store seems to work just find and we managed to get a few hundred products categorized without incident, but then we tried to blog.

    Every blog post on the site comes up with a product image holder, description and add to cart button. Of course posts do have that info so we're getting an error

    Warning: number_format() expects parameter 1 to be double, string given in /home/content/92/9351192/html/wp-content/themes/BoutiqueOldOne/functions.php on line 131
    followed by a bunch of other info like category lists, etc.

    I checked 131 and it's trying to grab the product price, so I should be getting the error. I'm just not sure why every post is trying to display product info.

    Any ideas on this?
    Really appreciate any assistance you can provide. :-)

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. smartdesi9n
    Member
    Posted 2 years ago #

    This is a problem similar to what we're having with regular pages. The cart plugin infiltrates all pages & posts, rather than just the e-commerce related pages.

    There is an additional thread on this topic at http://wordpress.org/support/topic/plugin-wp-e-commerce-every-page-a-product-page?replies=3#post-3096920

    Apologies for the pasting of the full link; the code/link buttons didn't do the trick.

    Between the two conversations, maybe we can come up with an answer.

    Thanks!

  3. TheLovelyWife
    Member
    Posted 2 years ago #

    Not much going on in the way of resolution to the problem. Refreshing permalinks, as suggested, did nothing. Big surprise there :)

    http://thelovelywife.com/category/Blog/

    I don't know if it helps but the above links to the way my blogs are being displayed. Really messed up.

    Hi Jon. I Googled my error message and found you in here trying to get us some help. You explain the problem much better than I can. I posted the same question a few days back in Word Press eCommerce forum. So far, nothing. I'm going to copy and paste yours and try again.

    Be well...
    TLW

  4. Jon Hardison
    Member
    Posted 2 years ago #

    Not at all TLW. We've been trying to figure this thing out but it's really weird. Not entirely sure what the heck the cause is. We'll get it, or go another way. I'm just really trying to avoid you having to reenter all of those products.

  5. Jon Hardison
    Member
    Posted 2 years ago #

    Thanx SmartDesi9n. Yeah, we can across that one too, but had no luck ith it. Really hoping we can get this resolved soon. As you can see, the site owner is getting pretty frustrated, and after all my picking I can figure out what's causing it. :-(

  6. TheLovelyWife
    Member
    Posted 2 years ago #

    Jon, I posted the question, as written by you, on the Get Shopped Forum. It's the home of the WP eCommerce plug in. They're telling me they don't think WPEC is causing the problem. He pointed to the error message and stated that it's clear the problem seems to be in the theme. He said before we do another thing we should update the theme and see if that resolves the problem. Can you do that for me? I'd do it myself but the last time I tried that I crashed my site. Another big surprise there :)

    He also said that WPEC would retain my entire product line should we find that we're going to have to change out my theme. It'll be messed up but doable. I'm not excited about the idea but, it may be the only option at this point.

    Please note: I've posted all this here so that others may benefit from it. Who knows what frustration we can spare someone else.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic