WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP e-Commerce] WP e-commerce > open_basedir restriction fix

[Resolved] [Plugin: WP e-Commerce] WP e-commerce > open_basedir restriction fix

  • Baden
    Participant

    @baden03

    After migrating to a new server, we where getting the following open_basedir restriction errors from wp-e-commerce v 3.8.8.5.

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(…/plugins/wp-e-commerce/wpsc-theme/) is not within the allowed path(s): …/plugins/wp-e-commerce/wpsc-core/wpsc-constants.php on line 301

    …on line 307

    We solved this issue by removing the wpsc_selected_theme entry from the wp_options table like so:

    Delete FROM wp_options WHERE option_name = 'wpsc_selected_theme'

    This is a workaround for less than optimal architecture of the wp-e-commerce plugin. Hope it helps someone.

    http://wordpress.org/extend/plugins/wp-e-commerce/

  • The topic ‘[Resolved] [Plugin: WP e-Commerce] WP e-commerce > open_basedir restriction fix’ is closed to new replies.