Support » Plugins » [Plugin: WP e-Commerce] Error Adding Products %wpsc_product_category% permalink

  • We are getting a 500 Internal Server error when we try to add a new WP e-commerce product. I am noticing that the category in the permalink is not populating.

    Our permalink structure in WP Admin looks like this before publishing:

    Even though we are receiving the server error, it is technically publishing the new products and we can manage/edit the new product after the error occurs.

    Any help would be much appreciated 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • Fred


    You should have solved this problem, but for others who could get the same, just notice that the permalink is displayed when publishing your product (or post). A draft post has no permalink.
    In order to check it without publishing it for anyone, set it as “private”.

    I had a similar problem. When I tried to use WPEC permalink, the links to single product page that appear either
    – on category page
    – on the ‘view product’ link (on the edit product page)
    – in the breadcrumbs (not the WPEC one)
    would be of this form :
    Changing manually the %wpsc_product_category% would work, so the problem is coming from the function returning the permalink (the WPEC one and the WP one that it calls)

    For me the problem was apparently caused by a conflict with the plugin qTranslate slug. It works after deactivating the plugin. Need to see if there are other bugs caused by not using it.

    Versions : qtranslate slug 1.1, qtranslate 2.5.31 (not the latest), WPEC, WP 3.5.1, localhost installation

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WP e-Commerce] Error Adding Products %wpsc_product_category% permalink’ is closed to new replies.