Support » Plugins » [Plugin: WP-dTree] Incorrect SQL syntax in WP-dtree breaks publishing/saving

  • Resolved dolemite


    …posts in lastest version of WordPress.

    I upgraded my wordpress from 2.6 to 2.6.5 recently. Everything was working fine until I went to write a post. When I hit the save or publish button a bunch of SQL errors appeared stating there was a problem with the syntax. It was suggested to me that I start disabling plugins and this was the first one I tried.

    Here’s the bug I opened. I disabled the WP-dTree plugin and everything worked after that.

    Here’s the link to the bug:

Viewing 5 replies - 1 through 5 (of 5 total)
  • It seems that the ORDER BY is not set properly. What version of WP-dTree are you running, and did you disable it before upgrading from whatever version you used previously?

    To fix your b0rked install:
    1. disable wp-dtree and delete it.
    2. get the latest version, upload and enable.
    3. make sure ‘wp_dtree_options’ gets created in your options table, and that the dtree_cache-table is created in your database.

    I’ll give this a try and see how this works.

    I followed the directions but regarding #3. None of them appear in the Database/get created.

    Is there a quick SQL query I can run to get these created?

    I figured it out. It looks like you not only have to disable the plug in but remove the widget from the active widgets list for it to work correctly.

    If the tables are not created on install of this plugin, there is something wrong with your WordPress or server setup. Judging by your other posts on trac and these forums, I find that plausible.

    The widget should have no bearing on this issue at all.

    Glad you got it to work though.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP-dTree] Incorrect SQL syntax in WP-dtree breaks publishing/saving’ is closed to new replies.