Support » Plugins » [Plugin: WP-dTree] 3.5 not converting &amp ; to &

  • usrbingeek

    (@usrbingeek)


    I don’t think previous versions had this problem, if they did, I never noticed it. But &amp ; isn’t being properly converted to a & when displayed.

Viewing 15 replies - 1 through 15 (of 19 total)
  • ulfben

    (@ulfben)

    Try this version and let me know if it works.

    usrbingeek

    (@usrbingeek)

    A link wasn’t included with your post.

    ulfben

    (@ulfben)

    michaelsharp

    (@michaelsharp)

    I just installed the new version and it’s taken out my category tree. everything else seems to work but the category tree no longer displays. You can see it here


    http://www.michaelsharp.org/

    usrbingeek

    (@usrbingeek)

    Thank you for your prompt assistance ulfben.

    I’ve tried that version you linked to and it now displays the symbol correctly in all but one of my categories. I believe that’s because it is being cut off by the “Characters to display.” It shows as “Computers &am…” Please see: http://www.newdealfinder.com/

    Additionally the entire category tree doesn’t display when viewed on some category pages. Example: http://www.newdealfinder.com/category/categories/computers-and-office/

    Firebug says, “unterminated string literal
    [Break on this error] c.openTo(‘Office”, true);\n”

    ulfben

    (@ulfben)

    usrbingeek – I’ve updated the character escaping some, it’s in trunk now. (the link posted previously). Try it out and let me know.

    I have no idea how you managed to get a line like c.openTo('Office'', true);\n" printed. The first parameter should always be a number. I’ve added an explicit check for that now so it shouldn’t break the tree, but I need to know what settings you used to get that result.

    michaelsharp – you should update too. I don’t know why, but the problem is with post numbers. Disable them on your category tree to get it back online.

    michaelsharp

    (@michaelsharp)

    Hi Ulfben,

    ya that works. thx

    m

    usrbingeek

    (@usrbingeek)

    Hi ulfben,

    I’ve tired the latest version in trunk and that corrected both issues.

    Thank you again for your quick assistance!

    ulfben

    (@ulfben)

    Thanks for getting back to me! I’m probably going to hang tight for another week to get more feedback from the “early adopters”, and then bump the version number a notch with all of these fixes.

    RavanH

    (@ravanh)

    I can confirm this beta fixes horizontal bar | being shown as &#124 on page links.

    RavanH

    (@ravanh)

    except double (“) and single (‘) quotes get escaped with a backslash (\) … is that really needed?

    ulfben

    (@ulfben)

    Thanks for testing. Yes, the escaping is necessary ‘lest you break the JavaScript.

    AndrewRH

    (@andrewrh)

    I now see \’ instead of just ‘ in my blog’s widgets. e.g. “Blog\’s Plug-Ins”. I’m using v3.5

    ulfben

    (@ulfben)

    AndrewRH – get the development version and let me know if the problem is fixed. I can’t reproduce the issue.

    http://downloads.wordpress.org/plugin/wp-dtree-30.zip

    anton_1978

    (@anton_1978)

    ulfben,

    I have installed proposed version of the plug-in. But the problem with categories still exists. BTW this bug occures only on the main page (see e.g. http://z86337.infobox.ru – main page, http://z86337.infobox.ru/test_wp/?page_id=125 – child page).

    In addition, source code on the main page contains following rows:
    <b>Warning</b>: substr_count() [function.substr-count]: Empty substring. in <b>/home/www2/users/z86337/htdocs/test_wp/wp-content/plugins/wp-dtree-30/wp-dtree_gen-functions.php</b> on line <b>173</b>

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: WP-dTree] 3.5 not converting &amp ; to &’ is closed to new replies.