Support » Plugin: WP Document Revisions » [Plugin: WP Document Revisions] Documents are corrupt and don't seem to be on the server at all

  • Resolved David M.


    I’m having the weirdest problem with this plugin.

    Everything seemed ok at first, I uploaded files and revisions and it worked as expected. Excellent plugin that solved a big necessity for us.

    Then some of the documents I had uploaded were corrupted and wouldn’t open when I downloaded them. I test again and upload more documents: some fail immediately, others work all right.

    However, what I download has correct filename and size, but it is corrupted.

    I tried to get the files directly from the site via FTP. But I couldn’t find them. I have multisite and upload folder is set as /wp-content/uploads. I have done several searches and the files do not seem to be there at all: for example, I uploaded several .ppt files, but none show up by searching with the FTP client, or by browsing /wp-content/uploads/2012/5 or anywhere else.

    Any idea? I’m completely disoriented. I have disabled other plugins installed after WP Document Revisions, but it didn’t change a thing.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Ben Balter


    A few things here. When you say searching by FTP, what do you mean? The file should be renamed on upload to a random hash, so you may not be able to detect the filename, but should be (by default) in wp-content/uploads/YYYY/MM/.

    Same size but corrupted is a good thing. It means it’s finding the file, something else is just getting in the way of serving it. Does the problem happen consistently across file types or only PPTs (testing, and have no troubling downloading PPTs)?

    Last, latest version of plugin and latest version of WordPress? What other plugins are activated? Any strange caching, etc. that may be causing it.

    If the site’s public, if you could either post or send me a link to a troubled file, it would be helpful to be able to look at the headers being served.

    You’re not the first to describe a similar issue, and it would be good to get to the bottom of this if possible.

    Thanks for the response Benjamin. Reader of your blog and fan of several of your plugins here!

    FTP: I mean that I tried to find the files “directly”, not going through WP. I FTP’d to the site and browsed all uploads folders. I knew that filenames should be hashed (I saw that in a localhost test), but I didn’t find anything at all. Particularly, I didn’t see any file with ppt extension. So I have no idea where it was getting the files from.

    Formats: I had the problem both with some PDF and some PPT.

    Versions: both up to date.

    No link, it’s an intranet.

    Plugins (nothing cache-related):
    Press this reloaded
    Sanitize Spanish filenames
    WP Mail SMTP
    WPTap mobile detector
    WP Document revisions
    Custom post types UI
    WP Use Parent Template
    Executable PHP widget
    Login Logout
    Wordpress Importer
    WP Use parent template
    Default Thumbnail Plus
    WP Post views plus
    CSV importer


    Plugin Author Ben Balter


    So to confirm, you upload a file, but they don’t appear in your uploads folder?

    You said you set the upload folder to /wp-content/uploads… that should be the *PATH* to the folder, not the URL (e.g., /var/www/wp-content/uploads/</code.).

    I have the same problem – the file looks to be there, downloads back fine, but either does not open (PDF) or shows gobbeldy gook (exel)

    Sorry that I haven’t answered yet, but I removed the plugin from my site, and I would need a free while to enable it again and do the required tests. But no free whiles for a while… 🙂 Sorry, I’ll try to do that if I can find some time.

    Just bringing this one back to life. I am having the same issue. Uploaded a bunch of documents previously. Approx. 10% of them appear to be corrupted, as in when you download the document. (typically .doc or .xls, they will show invalid characters.)

    Now, go to upload a new version of the document and viewing the files on the server, no new files on the server under wp-content/uploads/07. I tried uploading media through the WP dashboard with success, so it doesn’t seem to be a permissions/folder issue on the uploads folder.

    Latest version of WordPress and plugin.

    Intranet, so not public. However, happy to do any debugging to help get this issue resolved.

    Thanks Benjamin!

    Hi guys,

    got the same problem with doc docx and pdf files. txt files work fine.
    after downloading it, word i.e. wants to convert the doc file to open it. after that only hyroglyphs are shown…

    so i guess the file format gets changed for the files at least for more advanced file formats then txt.

    any ideas?

    thanks in advance!

    Ok found the bug.

    The plugin SEO Ultimate was responsible for the wrong file format after download.
    There’s a setting in the plugin module “title tag rewriter” which uses output buffering by default. Changing this to the second option “use filtering” solves the described problem.

    So, everybody using SEO Ultimate and having the same problem as me, please change your “title tag rewriter” settings.


    See also Issue #31.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WP Document Revisions] Documents are corrupt and don't seem to be on the server at all’ is closed to new replies.