Support » Plugin: WP-DB-Backup » [Plugin: WP-DB-Backup] Backup .gz cannot be opened

  • Resolved Rhand


    Installed this cool backup tool on a Dreamhost site as I love using this to backup. Could not open .gz anymore. Got this error: “not in gzip format” under Linux and under Mac is was just copied to the same file with extension .cpgz. Very odd!!. Had to use PMA to get a backup which did open without any issues..

Viewing 5 replies - 1 through 5 (of 5 total)
  • MichaelH


    When you used phpMyAdmin did you tell it to ‘gzip’ the file?



    Yes. Downloaded as a .gz from PMA as well. It “unzipped just fine. Tried the plugin WP-DB-Backup again, but still got a .cpgz instead of the .sql when I tried to unzip.



    Tried downoading backup created by plugin using Safari instead of Firefox this time. Safari tried to unzip it and failed with error:

    10/31/10 10:42:06 PM [0x0-0x190190][6792] Sun Oct 31 22:42:06 mysmbp Safari[6792] <Error>: CGImageSourceCreateWithURL: CFURLCreateDataAndPropertiesFromResource failed with error code -14.

    Somehow files were corrupted before they got to my box. This goes for dumping using PMA as well as the WP-DB-Backup plugin.
    Tested dumps made them with hexdump on got:

    mymbp:Backup me$ hexdump -C file.sql.gz | head
    hexdump: file.sql.gz: No such file or directory
    hexdump: file.sql.gz: Bad file descriptor

    Tried gunzipping .gz files in terminal and got.

    gzip: /Users/me/Webdesign/folder/backup/file.sql.gz: not in gzip format

    . This happens often when making a dump on a server that is located several 1000 miles away. They were corrupted during transfer. When I use WP-DB_Backup and e-mail the SQL dump all is well and the files can be gunzipped or unzipped without any issues.

    You may try removing the .gz filename extension. I’ve seen .sql.gz files that are actually just .sql files.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP-DB-Backup] Backup .gz cannot be opened’ is closed to new replies.