Support » Plugin: WP Db Abstraction » [Plugin: WP Db Abstraction] Permalink issue

  • Resolved MicioDue


    Waiting for a working 1.1.5 version of the plugin, here’s another issue. Same scenario of my previous post, WP and PHP updated to new releases (but the same is with with previous versions…
    Admin page options-permalink.php : Default setting is OK, any other setting causes a 500.0 error on this page! More strange, if you reload the page many times, SOMETIMES the page loads correctly.
    I tried a clean installation on a test Windows Server using Web Platform Installer and MySQL: no permalink issue. I then installed SQL Server 2012 Express and DB Abstraction plugin, then reconfigured WP site to use both: 500.0 error choosing permalinks other than default!
    I don’t know where this issue comes from, but it definitely seems to be related to a SQL Server-based WP installation.
    Tried different versions of the plug-in: 1.1.4, 1.1.3, 1.1.2, all the same.
    I found another user (“ravetroll”) experiencing the same issue in this thread so it’s not just me.
    Someone has any ideas? The rest of WP wite seems to work fine, but the same crash occurs on the whole site with a theme I recently bought that requires permalinks and my client is not happy…

Viewing 3 replies - 1 through 3 (of 3 total)
  • I had exactly the same problem. When trying to change Permalink from default to any other type. Howeevr, I noticed even though you get 500 error on web page, the table “WP_options” in MYSQL would still be updated with “permalink_structure” to the new permalink type, such as “/%postname%/”. I think the problem is translation layer failed to properly handle those special characters “/%” when retrieving the value of permalink_structure from the table.

    It seems to be the “/%” sequence to give the error, in fact. If you try to set permalink_structure to a completely different value, e.g. “/a”, of course it leads to 404 errors when browsing the site but does not cause pages to crash.
    I wonder if this can be solved on the plugin side or on the WP side itself…

    I solved! ๐Ÿ˜€

    I found an answer in authors’ home page stating this:
    This will mean, if you use mssql on Windows, that no unicode functionality will be available and you will not be able to change the character set or collation. The application will be โ€œlockedโ€ to windows 1252 for a character set. In addition there are limitations on column name length and other problems that may pop up.
    The best solution is to use pdo_sqlsrv or the sqlsrv extension โ€“ both are available precompiled and very easy to install on windows, and you can install them side by side with the mssql extension if youโ€โ€โ€โ€re using it for other legacy code.

    Replacing mssql driver with pdo-mssql driver seems to have solved the permalink issue, and perhaps many others I didn’t notice so far. ๐Ÿ™‚

    Perhaps ‘%’ character caused an Unicode misunderstanting? I don’t know, but if anyone tries this solution please confirm it works, thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP Db Abstraction] Permalink issue’ is closed to new replies.