Support » Plugin: WP Customer Reviews » [Plugin: WP Customer Reviews] Doesn't work at all — no way to add or view reviews

  • Resolved michaelnorth


    As others have mentioned, this plugin is not displaying either a way to create reviews or to view previous reviews — nothing on any pages. I’ve deactivated all other plugins on a WP installation with no content and still get nothing. I CAN edit the settings on the backend, but nothing is displayed on About, Home, or any other pages. Hope it can be fixed, would love to use this plugin. Right now, it’s broken.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Aaron Queen


    Hi Michael,

    Let’s get this thing fixed for you!

    Have you created a page for it to use and then gone into the settings for WP Customer Reviews and selected that page for it to use?

    If so, then the only explanation is the theme. So far, 100% of problems have been with themes that don’t follow the WordPress best practices guidelines.

    Could you provide the URL for the page that you picked for it to work with? I could check and at least make sure the CSS and Javascript are loading.. if they are, and there is no content… it must be a template in the theme..

    Don’t worry.. we’ll figure it out!

    Bompus — Thanks. I was using a default page (About), but let me create a new “Review” page and try again. I’ll report back shortly. Meanwhile, may I make a suggestion? It would be incredibly helpful if the plugin supported a review DATE. Many of the folks we work with have paper reviews and testimonials laying around. Rather than using the system date, or no date at all, it would much more meaningful to enter the actual date of the review. Google indexes that information, and a natural distribution of dates would go over well for presentation in local search results. I know the hReview spec does not REQUIRE a date, but it should go in there nonetheless.

    Plugin Author Aaron Queen


    You can edit the date to any date/time you wish in the admin area. Just click on the date when viewing reviews in admin and type in the new date 🙂 This was made specifically for that purpose of entering past reviews.

    Reminds me that we need to make some more documentation on the whole plugin, so thanks for that reminder.


    Aaron, thanks, mostly working now — yes, probably a tad more documentation would address most issues. I did need to create a new page, then choose that page in admin. So . . . great, I especially like the inclusion of the aggregate rating. I did notice a frustrating behavior though, perhaps you can check it out. If I made ANY kind of mistake, like not use “http://” or not fill-out a field, or hitting the submit key prematurely, or not submitting required fields, instead of failing gracefully, the plugin would crash to a 404 error . . . forcing me to start all over again. No public reviewer would bother to start again, and the review would be lost. I end up at when I should be brought back to the partially-filled form. Try it yourself: Am I configuring something wrong?

    Also noticed that if any edits are made to clean-up the review itself (using the red button), the line breaks are stripped-out and there doesn’t seem to be a way to override that behavior, even if pasted from an external text editor. Long reviews (from paper sources) become unreadable without breaks. I posted an example:

    Plugin Author Aaron Queen


    Updated to 1.1.9 to fix the 404 error issue. It was a weird jQuery conflict.. Doesn’t make sense:

    Old validation code (1.1.8):

    New validation code (1.1.9):

    The old was throwing an error on your blog saying first() function could not be found. I used the same version of jQuery on my blog and it worked fine. Oh well.. problem solved.

    The second issue was fixed in 1.2.0 — wow 2 releases in under 1 hour.. that’s what I get for not reading my inbox before I make a release. You should be able to make reasonable edits while preserving line breaks now.

    Let me know how it goes!

    Aaron — I’m stunned and amazed that you dealt with this so fast. Wow. Almost there . . . when I click the submit button in 1.2.0, nothing happens. Does not appear to be locking up or freezing, but the submission doesn’t happen. Please check when you get a chance. Also, could you point me to the code where I can tweak the styling of the form a bit?

    Plugin Author Aaron Queen


    Well.. that’s embarassing.. 1.2.1 is out and should hit the server in 15 minutes or less.

    Taught me a lesson for pushing out rapid releases 🙂

    Aaron — I can see you’ve been working hard on the plugin. This is great, thank you for putting in the skill and energy. May I bring an issue to your attention? Editing the review within version 2.0.1 of the plugin still strips out line breaks. Any way to tweak it so line breaks (space between paragraphs) are maintained in the editor?

    Plugin Author Aaron Queen


    I’ll check into this again, but I did extensive testing with editing reviews and it wasn’t stripping out line breaks for me. Very odd indeed.. I’ll do some more testing when I get a chance.

    Try to edit the review with line breaks and save. When you save and it switches back from edit to view in admin.. are the line breaks still there, or are they gone instantly?

    Also, after you edit, refresh the admin page and see if the line breaks are there or not. It uses two different processes but I did my best to preserve line breaks.. very weird.

    Let me know if you can do any debugging to product the problem again so I can test.

    Hi Aaron, I did a bit of testing for you: when I paste several paragraphs in the editor (with line breaks), then hit save, the line breaks disappear instantly — all the paragraphs are run together with just a space between sentences. When I refresh the page, no change, breaks are permanently stripped-out.

    Plugin Author Aaron Queen


    If you type in a line break, does it do the same? Or is it just when copying/pasting in the field?

    Yes, when I hit the edit button, then type-in some line breaks, they still evaporate once back in admin mode.

    Plugin Author Aaron Queen


    Could you visit this page: and have it email me your browser/OS details? aaron {[at]}

    I’ve tried Windows 7 with IE, Firefox, Chrome and cannot duplicate the issue, so I’m kind of confused as to what is causing it.

    I did add a possible fix in 2.0.6 , but without being able to duplicate it on my end, I’m not sure if it did anything or not.

    Plugin Author Aaron Queen


    Thank you. All fixed in 2.0.7 – the issue was a bug in IE 6 – IE 8 and how they translate line breaks into white space for text areas. Basically had to make a workaround to not use innerText or jQuery.text() , but it should behave now in all browsers.

    Try out 2.0.7 and let me know if that fixes it for you.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: WP Customer Reviews] Doesn't work at all — no way to add or view reviews’ is closed to new replies.