WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-Cumulus] Trying to get cumulus to work (14 posts)

  1. MrFlesh
    Member
    Posted 6 years ago #

    with a theme. I'm using Hybrid theme by justin tadlock. It has a tabs feature, when trying to use the standard cumulus code in a custom tab it throws an error. Justin had this to say.........

    "To use a plugin in a custom tab, it must return a value and not print or echo a value. You can't use everything with the tabs because not all plugins will return a value. "

    Is there a way to get cumulus to do this?

  2. Roy Tanck
    Member
    Posted 6 years ago #

    This will take a little bit of tinkering, but it should work. You'll need to edit the wp-cumulus.php file. Look for this bit:

    // template function
    function wp_cumulus_insert(){
    	echo wp_cumulus_createflashcode(false);
    }

    If you change the 'echo' to 'return' that will make the function return the output instead of echoing it out. Overwrite the original PHP file with your edited copy, and call the wp_cumulus_insert function within the tab.

  3. MrFlesh
    Member
    Posted 6 years ago #

    Still having issues. I switched echo to return. I've put the code

    // Custom tab 1
    	case __('Custom 1','options') :
    		// Input custom code
    		echo ''; _e('Please input your custom code','options'); echo '
    ';
    	break;

    where it says to put the code. It still isn't functioning. Do I need to make changes other than copy/paste?

  4. Roy Tanck
    Member
    Posted 6 years ago #

    I'm not familiar with this particular theme, so it's hard for me to help you with this. Perhaps you should contact the theme's author about this issue?

  5. MrFlesh
    Member
    Posted 6 years ago #

    He tells me the same thing. You should contact the themes author. Is there a way to verify that the plugin is indeed returning and not echoing now? Thanks for the help.

  6. MrFlesh
    Member
    Posted 6 years ago #

    Err I mean he says, contact the widget makers author.

  7. Roy Tanck
    Member
    Posted 6 years ago #

    OK, let's see that I can make of it then. Can you copy the same snippet of code you posted above, with your changes applied? Does that look something like this?

    // Custom tab 1
    	case __('Custom 1','options') :
    		// Input custom code
    		wp_cumulus_insert();
    	break;
  8. MrFlesh
    Member
    Posted 6 years ago #

    <?php case __('Custom 1','options') : ?>
    		<p>
    			<?php _e('echo wp_cumulus_insert();','options'); ?>
    		</p>
    		<?php break; ?>

    Here is the code I am being told to put in. This results in the following simply being typed in.....

    echo wp_cumulus_insert();

    You can see it at http://www.hornymelon.com In the tabbed section on the left. Is there any other code you need to see?

  9. Roy Tanck
    Member
    Posted 6 years ago #

    That snippet of code seems to make little sense. _e is a WordPress function that echos out whatever you put between the brackets, so PHP does exactly what it's told. Did you try my code (with the return we talked about earlier)?

    Or this without that modification:

    <?php case __('Custom 1','options') : ?>
    	<p>
    		<?php wp_cumulus_insert(); ?>
    	</p>
    <?php break; ?>
  10. MrFlesh
    Member
    Posted 6 years ago #

    Okay let me start over I've made some errors. I am using the options theme from justin tadlock. Here is what he said about this.....

    <?php case __('Custom 1','options') : ?>
    
    		<?php _e('Please input your custom code','options'); ?>
    
    	<?php break; ?>

    "To add your custom code, remove everything between the first and last line and input what you want. "

    I have tried putting the standard cumulus code in the "please input your custome code" and I have tried doing it the way you suggested in your last post. Both with cumulus echoing and returning. the custom tab remains blank in either case as you can see at http://www.hornymelon.com.

    "Did you try my code (with the return we talked about earlier)?"

    Which code are you talking about?

  11. MrFlesh
    Member
    Posted 6 years ago #

    Okay okay. Something crazy is happening. After I installed the sidebar "login plugin" on custom tab 1 it worked flawlessly, Then I reinstated it on custom tab 2 and set that tab up to be the first tab. I reinstalled the wp-cumulus on custom tab 1 and set that up as the second tab. Now neither of them will show properly, but if you hit the refresh button the wp-cumulus cloud appears briefly on the custom tab 2 and doesn't show on the custom tab 1. If I put the cumuls cloud as tab 1 it shows, but the "sidebar login" pluging will not show on tab 2. If I switch back to custom tab 1 wp-cumulus cloud does not reappear.

  12. MrFlesh
    Member
    Posted 6 years ago #


  13. Roy Tanck
    Member
    Posted 6 years ago #

    The way it's set up right now, it looks like Cumulus only displays when it's the first tab to be visible. Once it gets hidden it won't re-appear. The source code looks fine to me, but I'm no expert when it comes to Justin's themes.

    Looks like all the javascript is obfuscated too, so I can't dive into it.

    Perhaps having WP-Cumulus (which is Flash) on a fancy tab like this is simply too much to ask. I blame the theme ;).

    Any Options experts out there that want to give MrFlesh a hand here?

  14. MrFlesh
    Member
    Posted 6 years ago #

    Damn it. That's a bummer. Justin is no help, all I get is......."put the code in other than that I don't know I didn't mae the plugin" Is there any of the code that I could post here that would help?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags