WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP-CRM – Customer Relations Management for WordPress] Warning: Invalid argument supplied fo

[Plugin: WP-CRM – Customer Relations Management for WordPress] Warning: Invalid argument supplied fo

  • paudiefearon

    @paudiefearon

    Hello.
    I am just activated the CRM and got the following error on the

    Warning: Invalid argument supplied for foreach() in … /class_user_list_table.php on line 252.

    I am using 3.2.1

    I can’t then add users or anything on the pages.

    Any idea why this is being caused?

    Thanks
    Paudie

    http://wordpress.org/extend/plugins/wp-crm/

Viewing 7 replies - 1 through 7 (of 7 total)
  • wholmes

    @wholmes

    I got the same error… are you on local install by any chance? I uploaded to live server and did not get the message. It would be nice to use on local install though.

    Hi !

    I had same error. It come from the fact nothing was checked in the Settings > Main panel. Once I checked one box, it was ok.

    therealgorgan

    @therealgorgan

    Thanks Clorr! Your solution appears to work! I was like, “dang, I really want to use this plugin, poor me.” lol Thanks again Clorr!

    rweakly

    @rweakly

    Please help – I just activated this plugin and my site is DOWN with this error: Warning: require_once(/home4/fairhav4/public_html/wp-admin/includes/class-wp-list-table.php) [function.require-once]: failed to open stream: No such file or directory in /home4/fairhav4/public_html/wp-content/plugins/wp-crm/core/class_list_table.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required ‘/home4/fairhav4/public_html/wp-admin/includes/class-wp-list-table.php’ (include_path=’.:/usr/lib64/php:/usr/lib/php’) in /home4/fairhav4/public_html/wp-content/plugins/wp-crm/core/class_list_table.php on line 3

    I checked the server and sure enough there is no file: public_html/wp-content/plugins/wp-crm/core/class_list_table.php

    Any help would be greatly appreciated!

    Plugin Author Andy Potanin

    @andypotanin

    rweakly – what version of WP are you using?

    rweakly

    @rweakly

    Hey Andy,
    Thanks for the quick response! I FTP’ed into my server and whacked the WP-CRM plugin directory and the site came back up. I was running 3.0.? but I upgraded to 3.2.1, reinstalled WP-CRM, and it works like a charm! I think it’s going to do what we need. Thanks for putting it together!
    -RW

    Plugin Author Andy Potanin

    @andypotanin

    That’s what I figured. We’ll have to put something into the code to prevent the plugin from running on older versions of WP so this doesn’t happen to others.

    Also, in the future please consider using our forums for questions: http://usabilitydynamics.com/forums/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP-CRM – Customer Relations Management for WordPress] Warning: Invalid argument supplied fo’ is closed to new replies.