Support » Plugin: WP Bulletin Board » [Plugin: WP Bulletin Board] v1.0.3

  • ResolvedPlugin Author codebycarter


    I’ll probably use this topic or create a new topic each time there is an update to make you aware of exactly what changes have been made for those that don’t read the change log or don’t understand anything in the change log.


    Fixes 12+ issues including:

    1. [BUG] Permissions error bug a few people have been receiving. The fix applied should work for everyone encountering this bug but I’ve yet to confirm that. I wanted to release an update to at least fix the bug for a majority of people.
    2. [FEATURE] Guest Permissions allow you to set the permissions for guests just like you can with all other roles. The “Enable Guest Permissions” setting must be enabled. Guest permissions are displayed at the bottom of the Permissions table and is bolded for emphasis.
    3. [FEATURE] Tools – currently only one tool exists which allows you to refresh all roles that you’re using with WP. If you’re installing WPBB for the first time then you won’t need to do anything except refresh the rules if you add or remove roles using a role plugin. If you’re updating WPBB should also automatically do this for you but you will need to refresh the roles whenever you update the roles using a role plugin. Note: This only applies to those that have a role plugin installed which enables you to create new roles since WP does not currently allow you to do this without the use of a plugin. Other plugins may create custom roles but these are ignored by WPBB unless registered with WP correctly (this was one of the bugs with the permissions system).

Viewing 8 replies - 1 through 8 (of 8 total)
  • codebycarter,

    I am still receiving the error:

    You do not have the required permissions to access this forum!

    when attempting to access my forums using an administrator account on MultiSites. The index shows up fine, but cannot access any forums.

    Plugin Author codebycarter


    Yeah sorry about that I know that this is happening for two reasons:

    1. [FIXED] Custom permissions not registered with WP making the check believe the guest was a user and thus deny them access to the forum

    2. I believe that the wp_capabilities field isn’t being added / updated correctly by WordPress. If you have access to phpMyAdmin or a similar tool be able to see if “wp_capabilities” exists for the user you’re logged in as. Should be in the table “wp_usermeta” and be something like this:

    umeta_id	user_id	meta_key	             meta_value
    10             1            wp_capabilities       a:1:{s:13:"administrator";s:1:"1";}

    Something like that. If it doesn’t exist can you find this anywhere?:


    Thanks for your help and patience.

    It actually exists in wp_usermeta (I actually use a different prefix, so it uses MYPREFIX_usermeta) which may be what is causing the issue. Can you alter your plugin to utilize the prefix in the configuration file? Or maybe its because my table name is different than yours (possibly because of the Multi Site installation?)

    I’ve actually completely uninstalled this plugin and reinstalled it.

    Now I’ve gone ahead and recreated some test forums. I can now access the index and access the Forum as well. But now when I click ‘Create Topic’ I get a permissions error:

    You do not have the required permissions to create topics in this forum!

    Plugin Author codebycarter


    Should be fixed in 1.0.4.


    I am experiencing a similar issue. I want to enable guest posting, but when I try to tick the checkboxes for guest permissions I get an error message such as “Error Updating Forum ID 3”. I’ve tried this with “Enable Guest Permissions” on the settings tab both enabled and disabled. I’ve already updated to 1.04. Any suggestions?

    The website is but I’ve put the forum in maintenance mode for now.

    Other than this, the forum works great, thanks for creating it 🙂

    Plugin Author codebycarter


    Try going to Tools -> Refresh Roles. It’s possible that WPBB wasn’t able to do this for you so you will need to update the allowed roles in the database.

    Let me know if this works!


    Thanks for the quick reply! Yes, that solved the problem.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WP Bulletin Board] v1.0.3’ is closed to new replies.