WordPress.org

Support

Support » Plugins and Hacks » WP Bitly » [Resolved] [Plugin: WP Bit.ly] Fatal error after upgrading to 0.2.5

[Resolved] [Plugin: WP Bit.ly] Fatal error after upgrading to 0.2.5

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mark Waterous

    @delayedinsanity

    That’s interesting, are you running it alongside CakePHP by any chance? Cake is the only other place, and actually where I got the idea for my pr(), prd() and vrd() debug functions.

    That aside, I apologize for leaving that code in there without wrapping it in function_exists() calls, but if you open the wp-bitly.php main file and scroll down you will see a comment that says // DEBUG, TO BE REMOVED – delete this and everything below it and the plugin should activate for you.

    Great Mark!!
    Is working now!
    Great Plugin.. .

    Hi

    I also have a problem – WordPress 2.9.2 and version 0.2.6 of the plugin
    When I try to activate I get the message

    Plugin could not be activated because it triggered a fatal error.

    Any idea how I can get more debug info for you?

    Regards

    Elraidor

    Plugin Author Mark Waterous

    @delayedinsanity

    I just took a quick look – I added a deprecated.php file to maintain support for pre-3.0 versions of WordPress but I fudged one of the methods and I’m almost positive this is causing your issue. Is there any reason you haven’t upgraded your copy of WordPress? It’s known to work on 3.0 quite well according to other reports.

    PS: Apologies for the slow response. It’s been a hectic week and I’m traveling a lot right now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: WP Bit.ly] Fatal error after upgrading to 0.2.5’ is closed to new replies.
Skip to toolbar