Support » Plugins and Hacks » [Resolved] [Plugin: WP-Beautifier] Dependancy issue.

[Resolved] [Plugin: WP-Beautifier] Dependancy issue.

  • Howdy!

    I tried to install the plugin and go the following error:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected '&', expecting T_VARIABLE or '$' in /html/wp-content/plugins/wp-beautifier/beautifier.php on line 389

    I looked at the line and basically what it’s doing is appending to an array.

    See: http://php.net/manual/en/control-structures.foreach.php

    As of PHP 5, you can easily modify array’s elements by preceding $value with &. This will assign reference instead of copying the value.

    So the plugin is PHP5 dependant.

    $ php -v
    PHP 4.4.8

    My server doesn’t have it so I cannot use the plugin.

    Just a heads up!


Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: WP-Beautifier] Dependancy issue.’ is closed to new replies.