Support » Plugin: WP-AutoSharePost » [Plugin: WP-AutoSharePost] Problem to get the token

  • Hello,

    I install the plugin like written in the in install guide.

    Facebook app works, first time I get a error that FB cant handle the url. Later it works, and I need to choice and accept something. Step 2 was I need zu accept that the APP can write messages as all my facebook activities (I handle some side there). I accept, but then nothing happen, I just redirected to my login-screen from the wordpress side. And no token in the administration field.

    I tried to us, but Plugin send the error, no token avaiable.

    if I now press the token request link, I also just come back to the login screen from my wordpress.

    What happen, waht I can do? πŸ™‚ Thanks in advance

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author BenjaminPaap



    did you activate cookies? Seems that if you leave your wordpress admin page that your session is gone. If you use cookies and your session is still alive then you should be redirected to the settings page and the token will be saved in the settings.


    mhh, cant be, because also if I login and try it direct to do, I logged out. All other things work well, just with that link I have this problem. I have open my admin side the whole day here, and it works.

    I will try with delete and install again. Maybe it work.


    I tried much things, the redirect to my login (and Im loggend out from my WP) happen when I use different Domains in my FB applictaion.

    I use
    App Domains :
    Website with Facebook Login :
    then works up to the error message from FB 191.

    If I use in “Website with Facebook Login” http:// and not httpS:// then I get redirect and log out.

    So, if I now use this combination wich works, then I see a FB error :
    (sorry for German, but I think 191 as code is known)

    Mit Applikationname ist ein Fehler aufgetreten. Bitte versuche es spΓ€ter noch einmal.

    API Error Code: 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Die Anwendungseinstellungen lassen die angegebene URL nicht zu.

    In my WP now Im not logged out.

    Could be SSL a Problem? I host my side with 1&1 and have not a own SSL certificate, just a SSL proxy. For SSL I need to call my domain like that : – then I see my side with SSL.

    Maybe you have a idea?

    I have some own Applications work in my FB side, but always the automatic postings make me trouble. πŸ™‚

    Thank you

    ok, forget post before, to add the application not work again, because the application was added… but I not receive a token.

    Now I always can add the application to my FB, just need to delete before in my account.

    BUT :

    I see in my Facebook now in Account settings, applications : My application… but no token again. πŸ˜€

    this I do:

    I use for App Domain :
    for Facebook Login Side :

    Then I press the button “request token”
    Then I see first dialog and use “go to application”
    Then I see second dialog and allow that the App can login as my 5 FB side’s and can post status and pictures.

    But again, after that I just see my Login Screen admin-area from my homepage

    In my FB I see the application in my application list. She is added.. but no token.

    I not know to do more now.

    Plugin Author BenjaminPaap



    can you please contact me by mail to I’m german too and I think in this case it is better to have a direct contact. Maybe you can give me some access to your wordpress installation so I can test this.

    Hello, thank you very much, I will do that πŸ™‚

    Hi Benjamin,

    I have exactly the same problem as kalle0. If you solved it, please let me know how.


    Plugin Author BenjaminPaap


    In this case the problem was that the same session was not restarted by the server. You have to make sure, that the session cookie stays alive and the correct session will be used again.

    You can also try to disable other plugins one by one and try to get your token then. Maybe another one interferes with this one.

    Hi Benjamin,
    thanks for your replay. Your are right, as soon as I request the Facebook Access-Token the system loggs itself out of wordpress. I deactivated plugins but it did not solve the problem.
    How can I make the cookie stay alive?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WP-AutoSharePost] Problem to get the token’ is closed to new replies.