Support » Plugin: WP-AutoSharePost » [Plugin: WP-AutoSharePost] No facebook user supplied. Did you give all permissions?

  • Hello,

    after following the steps in yours descritpion I wanted to request the Facebook Access-Token. I accepted everything and got this error message:
    “No facebook user supplied. Did you give all permissions?”

    By the way: I want to post my articles on a facebook page. Under which name will it happen? My personal name or the facebook page name?

    Thank you

    http://wordpress.org/extend/plugins/wordpress-autosharepost/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Just came across the same error “Facebook Error:
    No facebook user supplied. Did you give all permissions?” upon following setup instructions.

    Plugin Author BenjaminPaap

    (@benjaminpaap)

    Hi guys,

    with a quick check yesterday I was not able to reproduce this issue. I will check this again this weekend and supply you with an update.

    With WP-AutoSharePst, Do I need to have facebook account first to post articles on facebook page?

    Plugin Author BenjaminPaap

    (@benjaminpaap)

    Hi,

    there is a new version online at github. It’s not completly done yet so I won’t put it on wordpress.org yet.

    You can download it here: https://github.com/benjaminpaap/WP-AutoSharePost

    @cfm168: Of course you need a facebook account to post articles on a facebook page. And you have to be the administrator or one of them to publish to the page’s wall. I think I do not understand your question correctly.

    Alternatively, use TwitterFeed, search on Google. It allows you to automatically update all your social accounts at once. Plugins also increase the site speed.

    Plugin Author BenjaminPaap

    (@benjaminpaap)

    TwitterFeed seems great for users who don’t know how to create their own apps on facebook or twitter. The problem I see is that if the service is down no one can share their blog posts. Another thing is that as far as I can see you have to send your text to them and they will share the post to you. I don’t want to know what they do with all the data.

    @benjaminpaap That latest version has fixed the issue. Authenticated first time and filled in the correct Page Name automatically. Cheers

    Plugin Author BenjaminPaap

    (@benjaminpaap)

    Hi, sounds great if you have any feature requests just mail me.

    I mark this as resolved.

    Hello…
    I have the same error, even with the lastest version…

    Hi there-

    I’m having the same problem, although it seems to also alternate between two other errors.

    Under Settings › WP-AutoSharePost, the User/App/Page Name and Token fields are greyed out. I assume this is normal until the token is requested?

    Here are the error messages I get:

    1. No facebook user supplied. Did you give all permissions?
    2. Could not find any app associated with this user with appId “”.
    3. An active access token must be used to query information about the current user.

    It seems to 1-2-3, then back to 1 in perpetuity. But all I’m doing is clicking on “Request Facebook Access-Token”.

    I’m at a loss. Any thoughts?

    Thanks and best wishes,
    Kristen

    PS – This thread is a month old from the last reply. I have version 0.2.5. This is the newest one, yes? Looking at the github link, I wasn’t sure.

    Plugin Author BenjaminPaap

    (@benjaminpaap)

    Hi Kristen,

    the fields you mention are always greyed out because they only have some informational character.

    Did you login to facebook with the user who administers the page you supplied in the Page ID field? Did you fill out the “App ID” and “App Secret” fields?

    Hi Benjamin,

    Wow – thanks for responding so quickly!

    Yes. 🙂 I had the fields filled out and I was logged in. Not sure what I could be doing wrong? I tried taking out the page ID, in case, idk, there was something with that. And I double-checked the App ID, etc.

    Is there anything special in the app creation that I could have missed? Does it matter what the Namespace is?

    Thanks for your help. I really do appreciate it. 🙂

    Best wishes,
    Kristen

    Plugin Author BenjaminPaap

    (@benjaminpaap)

    Hi Kristen,

    had no computer at the weekend so I was not able to answer your questions. Can you please check in your Facebook Account Settings if your app is shown under app settings? If yes try to remove it and try to get an access token again.

    Hi Benjamin!

    Same issue here, even after installing the new version. It still says

    “No facebook user supplied. Did you give all permissions?” right after I gave all requested permissions to the app.

    Even when removing the permissions and request that access token again doesn’t work.

    Twitter App and bit.ly work fine btw.
    Thanks in advance!
    Christian

    When I wait some time, this appears:
    “Could not find any app associated with this user with appId “”.”

    After requesting the token again the following message appears:
    “An active access token must be used to query information about the current user.”

    Requesting again and we’re back with
    “No facebook user supplied. Did you give all permissions?”

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Plugin: WP-AutoSharePost] No facebook user supplied. Did you give all permissions?’ is closed to new replies.