WordPress.org

Forums

WP Ajaxify Comments
[resolved] [Plugin: WP-Ajaxify-Comments] Post reloading to a 404 (11 posts)

  1. Dave
    Member
    Posted 3 years ago #

    Interesting plugin.

    Had the problem of when a comment is submitted it the page would reload but it was reloading to a 404.

    The main url is unchanged. But it's adding a random numbers to the end of the url.

    Any ideas?

    http://wordpress.org/extend/plugins/wp-ajaxify-comments/

  2. janjonas
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Dave,

    I think this bug has been fixed in the developer version (http://downloads.wordpress.org/plugin/wp-ajaxify-comments.zip) which will hopefully be released soon.

    Nevertheless the complete page reload (which seems to cause the problem on your blog) is only done in fallback mode, e.g. if the comment list could not be replaced after the comment has been posted using AJAX. Could you please enable the debug mode and post the output of the browser console? It seems, that one of the selectors is not configured properly for your theme.

    Regards,
    Jan

  3. Dave
    Member
    Posted 3 years ago #

    Hi janjonas,

    I was using #comments-list as #comments was not reloading the page nor showing the new comment.

    It's not 404ing any more with #comments. Just wondering if there's something not hooking due to caching?

    But I have to manually reload the page for the comment to show: ideas?

    BTW I just tried the dev version and same issue regarding the comment not showing unless you manually click reload.

    BTW 2 can't see debug info showing anywhere after enabling it, source, or on page.

  4. Dave
    Member
    Posted 3 years ago #

    Hi janjonas,

    Okay just an update on the Dev version.

    I went back to #comments-list

    And the page is now reloading. But it's the whole page. Which kinda defeats the purpose of ajax comments in my view.

    Also there's a number strung onto the end of the url now. Not sure how that will look to search index's if it gets saved.

    Again, I'm not sure if this is how the plugin is meant to work, or if there's still an issue?

    If you take a look at how http://wordpress.org/extend/plugins/ptm-ajax-comments/ processes comments it works very nicely with the comment showing and no page reload or strange code at the end of the url.

    Would be interested to hear back from you as otherwise your plugin works very well with some other things I'm trying to do!

  5. janjonas
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Dave,

    To see the debug output you can use the Chrome browser or Firefox with the Firebug extension. Just press F12 to open the developer window and open the console view and open your blog.

    If your blog public available, I could try to reproduce your problem and find out the correct configuration options for you?
    If the plugin is configured properly no complete page reload is necessary to post and validate comments.

    Regards,
    Jan

  6. Dave
    Member
    Posted 3 years ago #

    Hi Jan,

    Thanks for the info.

    Yes, I got debug working

    "[WP-Ajaxify-Comments] Search comments container (selector: '#comments-list')... Not found"

    Is highlighted.

    Weird as when I just use default #comments nothing reloads. with #comments-list it reloads, but it's the whole page.

    I'm using a mirror site, not the live one to test all this. Happy to send a non-public url if I can? email or twitter etc as I don't think DM is possible on wordpress.org forum

  7. janjonas
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Dave,

    You can send me a message on my contact page http://blog.janjonas.net/contact.

    Best regards,
    Jan

  8. Dave
    Member
    Posted 3 years ago #

    Hi Jan,

    I just sent some details via your contact page.

    Many thanks

    Dave

  9. janjonas
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Dave,

    please try to use the following settings:

    Comment Form Selector: leave empty for default
    Comments Container Selector: ol.commentlist
    Respond Container Selector: leave empty for default

    Hope this helps,
    Jan

  10. Dave
    Member
    Posted 3 years ago #

    Hi Jan,

    That seems to have worked! Thank you for taking the time to take a look at it.

    I'm now doing some further testing with some mods for spam etc, but it's certainly taken care of the main issues. Including the strange numbers in the url. Now it does not change at all, and page does not fully refresh only the comments as it should.

    Great stuff and two thumbs up for the support. Thank you once again

    Dave

  11. janjonas
    Member
    Plugin Author

    Posted 3 years ago #

    You're welcome :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Ajaxify Comments
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.